-   Linux - Hardware (
-   -   Keyboard & mouse sometimes non-responsive in liveCD openSUSE, ps/2 interface (

surfreak 06-24-2009 02:23 PM

Keyboard & mouse sometimes non-responsive in liveCD openSUSE, ps/2 interface
Unnecessary info that I should erase but left here anyway:
So I pop in the CD during a windows session, reboot and run openSUSE (11.1) from CD. Keyboard works fine during the "openSUSE Installer" screen (I can scroll up and down with arrow keys, typing works), but upon loading/login it ceases to function. I've tried using the SAX keyboard setup while logged in to no avail. Keyboard is HP 5187-7583, ps/2 interface, hp pavilion a1328x computer with pentium 4 processor.

Start reading here:
openSUSE 11.1 liveCD, hp pavilion a1328x, cheap logitech ps/2 and USB mice, hp 5187-7583 keyboard

Alright, so initially I tried booting with my ps/2 mouse & keyboard hooked up. Keyboard worked, mouse didn't. Then I rebooted with USB mouse and ps/2 keyboard - mouse worked, keyboard didn't. Tried switching mice after login to no avail (ps/2 still didn't work), tried SAX keyboard and it still wouldn't type. Now I just tried restarting again with ps/2 keyboard and ps/2 mouse (USB mouse disconnected), both work perfectly.

Is this a common issue with running from liveCD, or is this something I can look forward to upon install?

lukeiamyourfather 06-25-2009 08:12 AM

I've had the same issues with Ubuntu 7.04 and 7.10 LiveCDs. It's been fixed since then though. However, after I installed it, (just used usb mouse and keyboard for install), I no longer had this problem.

Any particular reason you're using SuSE?

All times are GMT -5. The time now is 05:47 AM.