-   Linux - Hardware (
-   -   Kernel Panic with D-Link DWA-525 (RT3060-based) PCI wireless NIC (

Eldarby 03-18-2012 01:19 AM

Kernel Panic with D-Link DWA-525 (RT3060-based) PCI wireless NIC
I bought and installed D-Link DWA-525 PCI card to replace my older wireless NIC. This card has a Ralink RT3060 chipset. My distro (Salix OS 13.37, based very closely on Slackware 13.37, same kernel and everything,) didn't come with modules for this, so I downloaded the appropriate source package from Ralink's website. I set it up by doing the following...
  1. edited os/linux/ as per the readme for wpa_supplicant support
  2. su
  3. make (yeah, this needs to be compiled as root, strangely)
  4. make install
  5. edited /etc/modprobe.d/blacklist.conf to blacklist the old rt2800pci driver
  6. rebooted
  7. made sure rt3562sta module was loaded
  8. checked iwconfig to see if my card was found
  9. changed wicd's settings so that ra0 was being used instead of wlan0

Everything was working fine up until this point.

Then I tried to actually connect to my router.

As soon wicd attempts to put my interface up, I get a freakin' kernel panic! Every time! I've had to chmod -x rc.wicd so I can at least have a usable offline system until I get this figured out. Typing from my laptop right now since the desktop's out for the moment.

I would like to copy the output of the kernel panic for someone who may be able to make more sense of it, but I don't have much experience troubleshooting these kinds of problems, so I'm not sure how to go about capturing it so I can paste it (after all, the system is completely hung once the panic happens.) The output clearly implicates the rt3562sta module as being responsible. If there's anywhere in /var/log that saves that output, where would I look for it so I can share it here or pastebin it?

I've been having a very sober and frustrating St. Patty's night trying to get this figured out. I've scoured search engine results for several hours, using various combinations of "DWA-525", "RT3060", "rt3562sta" and "kernel panic" in my search terms, among other things. Haven't found very many relevant results, maybe this card/chipset is new, I'm not sure, but the best I've found was one person on a forum who was having the same problem in Ubuntu. That person solved it by removing ndiswrapper, but that fix doesn't seem to work in my distro, as I'm still getting kernel panics all the same.

I'm stumped. Please help. Slackware users, please share your solutions if you have them especially, the distro I run is almost identical to Slackware in many ways and I've had a lot of past success fixing problems and implementing things in Salix by using the exact same solutions and methods that work for Slackware. I'm probably going to go back to plain Slackware once I get this card running anyway.

I would ask Ralink directly, but their tech support staff only speak Taiwanese. Sure wish I knew how to speak it! I would also ask D-Link, but this blog post I stumbled on during my searches for a solution quickly discouraged me from wasting my time.

H_TeXMeX_H 03-18-2012 05:01 AM

I recommend you get the latest kernel and enable the RT2800PCI driver and also possibly the experimental options on it. Also download and install the firmware:

Eldarby 03-18-2012 01:36 PM

Well, I got rid of the new module I compiled and went back to the rt2800pci module like you suggested. The experimental options were enabled in the kernel already. I couldn't get any wireless signals when I scanned, and I know there's over a dozen APs within range of my apartment, not to mention my own.

Then I upgraded to the latest kernel, to see if that would help. I downloaded the latest kernel-* packages (including the firmware) from -current on my laptop, put them on a flash drive, took them over to my desktop, installpkg'd them, but now wicd won't even run because of errors that seem to relate to dbus and python being too old. Gah, I don't think Salix is supposed to touch the -current stuff anyway, I don't know if I should attempt upgrading any more packages, I'm going to revert back to the stable 13.37 packages for now.

I would gladly replace Salix with plain Slackware just to see if upgrading to -current properly would fix the problems, but wireless is all I've got for connecting to the internet (and, thus, upgrading) on my desktop. Maybe if I get a crossover cable I could bridge my laptop to my desktop for long enough to get it up to date. It may be a while before I can go buy one but I'll keep my subscription to this thread and update with more info as soon as I can.

H_TeXMeX_H 03-18-2012 01:55 PM

If it's hard to upgrade, at least try installing the firmware if it's not already installed. I would compile my own kernel, not upgrade to -current like that.

Eldarby 03-18-2012 04:40 PM

I figured upgrading my kernel would be the "safer" option, I trust the geniuses behind Slackware to know how to make a better kernel than I could. As for the firmware, I followed your link but there still doesn't seem to exist a .bin for rt3060. The closest I can find is rt3070.bin. The HCL said this card should work, I hope we can figure out how to make it happen.

I will perform an upgrade/change from Salix 13.37 to Slackware-current on my desktop. I've already done that on my laptop and everything's running beautifully. I guess this hardware issue is the just the excuse I need to get out to the computer hardware store tomorrow, get that crossover cable and maybe a hard drive too. I'll post how things go once that's done.

H_TeXMeX_H 03-19-2012 04:35 AM

Just install all the firmware in the zip file you get from git, and it should choose the right one automatically.

Eldarby 03-22-2012 07:34 PM

I did what I mentioned, I ditched Salix and put Slackware on here, got it up to -current. Wireless drivers work like they should, now. Thank you, kernel 3.2.7!

I think I'll stick with Slackware over Salix now, at least I can upgrade my kernel a lot more easily if I need to. I am confident enough to use Slackware, even at -current, I was mostly just using Salix for the benefit of less experienced users on this shared computer. Doesn't matter though, they're eager to learn :).

Thanks for suggesting a more recent kernel. I'd call this solved.

Eldarby 03-23-2012 11:25 PM

That'll teach me to be confident. -current locks up Xorg for me, so I had to go back to stable 13.37. I was hesitant to compile my own kernel earlier because I was just worried I'd screw something up, but then I found Alien Bob's kernel compilation guide, so I decided to follow it.

Sure enough, I managed to avoid hell by following Bob's good advice and compiled a great new kernel. Then I added the firmware package you linked to for good measure, and my wireless card works perfectly!

So there's a better solution than all the trouble -current is worth. Thanks again for all your help!

All times are GMT -5. The time now is 02:39 PM.