-   Linux - Hardware (
-   -   Kernel Panic (hdd problem) (

frzburn 02-17-2004 09:46 AM

Kernel Panic (hdd problem)
Hi all,
I have Slackware 9.1 installed on my machine for a little while. Never had problems. Since last Sunday. The computer was running in Windows, since my dad used it. So I reboot it and lunched Linux. It started its initialisation script and then : "Kernel Panic : Unable to mount root ..." something like that. So I tried a bootdisk and everything, but nothing worked. It was late, so I decided to go to sleep.
Monday, after college, I decded to try it again. I booted it up, selected Linux, and MAGIC! It was working. No problem at all. (Well, it did some kind of scandisk during the initialisation). So I played America's Army, UT 2004 ;) and had a lot of fun. Then my mother had to use the computer, sO I rebooted it. Se used it, in Windows, no problem. When I took it back, I rebooted it again to lunch Linux, and guess what? Kernel Panic! =(
So I tried bootdisk again, and all I could do, but nothing worked. Then I opened the case, unplug my CD-ROM and power back on my computer. Linux lunched with no problem at all. (My hdd and CD-ROM are on the same cable). :scratch:

That's it. That's my life. ;)
Nan seriously, do you know why this error happens, and how I could fix it?


P.S.: Sorry for my bad English, you surely noticed I wasn't speaking English frequently =)

yowi 02-17-2004 12:45 PM

Have a look through the logs of the boot process (probably /var/log/...) and see if you can find anything that looks guilty in there.

All times are GMT -5. The time now is 11:19 PM.