LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 04-14-2004, 07:04 PM   #1
wesmont
LQ Newbie
 
Registered: Apr 2004
Distribution: debian sarge testing
Posts: 5

Rep: Reputation: 0
Kernel 2.6.x running in modulated clock mode


Ever since i started using kernel 2.6, I keep getting messages saying my cpu temperature is above threshold and the system is running in modulated clock mode. This has happened with 2.6.3, .4, and .5. Any consoles I have open will give me this message several times a second.
This happens anytime I run a program that uses my 3d card (Radeon) such as tuxracer and some screensavers. It also happens during other intensive tasks, ie compiling a kernel.
I doubt that my temperature is really dangerously high since these are things I had done under kernel 2.4 with no problem.

Anybody else have this problem?
Is there a way to change the threshold, disable this feature, or otherwise solve this problem?
 
Old 04-14-2004, 07:55 PM   #2
geekzen
Member
 
Registered: Mar 2004
Location: Canada. The Great white north.
Distribution: Debian Sid
Posts: 183

Rep: Reputation: 30
If you recompile, removing support for temperature sensors, then perhaps this may go away. A better thing to do would be to figure out IF your CPU is too hot, and if not, how to adjust the "Too Hot" temperature.
 
Old 04-15-2004, 01:23 AM   #3
wesmont
LQ Newbie
 
Registered: Apr 2004
Distribution: debian sarge testing
Posts: 5

Original Poster
Rep: Reputation: 0
ok, installing a kernel module for my sensors (asb100 for ASUS motherboard) has allowed me to watch the cpu temp with gkrellm. As i compile a kernel, the 'temp2' reading progresses from about 36 degrees C to about 57, where it starts complaining.
Other readings, which remain steady are:
cpu speed: 1.6 ghz
temp1: 34 C
temp3: 125 C
temp4: -46 C

57 C sounds pretty hot. if it is actually that hot, i probably need a way to slow down more imperceptibly.
or are the readings wrong?

i opened up my box, and with the case open, i am actually able to get through a kernel compile..
i'm surprised it's getting so hot, its in a roomy aluminum case with good fans..

a lot of my normal desktop operations (opening apps and browsing filesystem) sped up significantly when i switched to the 2.6.x-1-686 kernel so i'd like to keep it, but this is a hassle..

anybody else's 2.6 kernel overheating their cpus?
maybe theres a way i can ask it to slow down sometimes?
 
Old 04-15-2004, 05:54 PM   #4
geekzen
Member
 
Registered: Mar 2004
Location: Canada. The Great white north.
Distribution: Debian Sid
Posts: 183

Rep: Reputation: 30
Well, it soudns as if you Actually ARE having a heat problem. You may want to invest in either a better CPU fan/heatsink, or alot more fans. Is this an AMD, because AMDs actually (in my experiance, i have a 2400+) run hot. (mine is 50.. 53. Course, this is a win box. )
 
Old 04-15-2004, 07:10 PM   #5
wesmont
LQ Newbie
 
Registered: Apr 2004
Distribution: debian sarge testing
Posts: 5

Original Poster
Rep: Reputation: 0
Well, it's an Intel P4.. I guess it's getting really hot.
I'm surprised I haven't seen anybody else have this problem (except laptop users) from searching help forums and google.
This suggests to me that it is, like you said, a matter of me not having enough fans or good heat sink.
But I'm still surprised that this computer has run about 20 hours a day for at least 2 years and never had a similar problem until I started using the 2.6 kernel. Does this mean that it is able to realize my processor's potential in ways previously impossible? who knows...

I've noticed that modulated clock mode isn't so bad. Mouse and windows are still responsive. Tuxracer stutters, but I'll be ok. The main noticeable effect is the infernal messages that are broadcast on any and all consoles I have open. I like knowing that my cpu temp is too high, but I don't want to know several times a second.. It is a dilemma I guess.

Anybody have a clue on how I might be able to stop these messages from being broadcast? Here is what one looks like:
Message from syslogd@wes at Thu Apr 15 20:12:15 2004 ...
wes kernel: CPU#0: Temperature above threshold
 
Old 04-15-2004, 07:29 PM   #6
wesmont
LQ Newbie
 
Registered: Apr 2004
Distribution: debian sarge testing
Posts: 5

Original Poster
Rep: Reputation: 0
Looking at this page:
http://support.intel.com/support/pro...Specifications

Intel tells me my P4 can run with a maximum case temperature of 75 C..
I guess maybe the cpu temperature given by my lm-sensors could mean a different thing than the 'case temperature'.
But it seems to me like they might be the same thing, in which case I could turn up my max heat from 57 C to 70 or even 75 C. Sounds hot to me, but the worst that can happen is I have to buy some new hardware, which can be fun from a non-economical standpoint.

So I guess I'll try and figure out how to increase my max temperature... unless somebody tells me that 70 C is way too hot and I would be crazy to do this.

Thanks geekzen for your replies, btw. I know this is not a fun problem to think about.
I'm hoping that if anybody else has this problem, this thread will make information easier to find for them than it originally was for me.
 
Old 04-15-2004, 10:21 PM   #7
wesmont
LQ Newbie
 
Registered: Apr 2004
Distribution: debian sarge testing
Posts: 5

Original Poster
Rep: Reputation: 0
I commented out the line in my /etc/syslog.conf that says:
*.emerg *

so emergencies are no longer broadcast to all users

works good enough for me
 
Old 04-15-2004, 10:31 PM   #8
geekzen
Member
 
Registered: Mar 2004
Location: Canada. The Great white north.
Distribution: Debian Sid
Posts: 183

Rep: Reputation: 30
Course, this means that another Emergency wont be broadcast... not good.
Someone needs to help you here.... This post needs to be moved to hardware. I will do the report/modcall.
 
Old 04-18-2004, 07:24 AM   #9
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594
//Moderator.note: summon.mod succeeded, move.thread granted.
 
Old 04-18-2004, 12:52 PM   #10
geekzen
Member
 
Registered: Mar 2004
Location: Canada. The Great white north.
Distribution: Debian Sid
Posts: 183

Rep: Reputation: 30
Thank you much.
 
Old 05-27-2004, 09:41 PM   #11
bokmann
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Same problem

While searching for information on the problem I'm having with Fedora Core 2, I found this page. It describes myproblem exactly. I am running the Gimps client (not just stress testing - I participate), and after abot 15 minutes, I start getting the emergency messages to all my consoles... about 8 a second, to the point where I actually cannot type anything useful and kill the process (slightly different flavor with my problem - as a hyperthreaded processor, I have 2 CPUs screaming at me.

While it is a little hot, it is within the range the processor should be fine with (about 60 degrees) according to intel's website.

I don't want to just turn off logging the .emerg to the console... that would be wRong... It is also annoying that my messages file is getting HUGE. I would prefer to just turn off this particular warning, or (ideally) make the processor not complain until it is a little hotter (but I think the throttling back is hardware controlled).

Any help on this issue?
Thanks,

-db
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running in modulated clock mode... by mistake? sp406 Linux - Software 8 01-30-2008 03:51 PM
PHP clock (text mode) swmok Programming 2 05-03-2005 05:57 PM
CPU#0:Runing in modulated clock mode shams Mandriva 2 05-26-2004 05:12 PM
The clock is running too fast satimis Linux - Hardware 4 03-19-2004 09:23 PM
System clock is running too fast on RH 9 jimieee Linux - General 0 01-06-2004 11:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration