LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   kernel 2.4 -> kernel 2.6 problems with Maxtor SATA (https://www.linuxquestions.org/questions/linux-hardware-18/kernel-2-4-kernel-2-6-problems-with-maxtor-sata-279422/)

Bultot 01-18-2005 03:58 PM

kernel 2.4 -> kernel 2.6 problems with Maxtor SATA
 
Hello,

I'm new to linux and i've completed my debian 'sarge' netinstall. Now when I want to compile a new kernel I get an error:


VFS: Cannot open root device "sda3" or unknown-block(8,3)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(8,3)

I know that if I switch from kernel 2.4 to 2.6.10 I have to use the scsi drivers for my SATA disc.
So I've changed the hde3 to sda3 in my grub loader.

Still I have the same problem here.


I've uploaded my .config file and my outputs of fdisk etc here:
http://www.easychilling.net/tmp/linux

I hope someone can help me...

ryeman 01-18-2005 10:13 PM

Well, I don't have an answer for you other than try a different HD. I have had many problems with Maxtor. It kept dropping the boot sector. I thought it was a virus until I ran the maxblaster util from Maxtor. Of course the warranty ran out just prior to the problem!!!

Bultot 01-19-2005 01:58 AM

No, it has to do with the hde -> sda conversion.
I've installed a clean 'netinstall' debian directly with kernel 2.6 by typing "linux26" at boot and my system works now. I think there has to be more to change with upgrading from kernel 2.4 to 2.6


All times are GMT -5. The time now is 11:43 PM.