LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   K3B - No support for ATAPI with cdrdao (https://www.linuxquestions.org/questions/linux-hardware-18/k3b-no-support-for-atapi-with-cdrdao-115928/)

perry 11-14-2003 08:10 AM

K3B - No support for ATAPI with cdrdao
 
just managed to get my cd-rewriter (/dev/scd0) working thanks to some wonderful help from people here - got this problem just as i got inside of k3b (looks good but what is it all about)

No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems.


thanks

- perry

Hammett 11-14-2003 09:03 AM

You can use cdrecord instead, via K3b or via console. It works really great ;)
You only have to install the pakage and that's all (if using debian or RH via apt-get). Otherwise you'll have to compile it and install it, but isn't so complicated

Hope it helps

iro 11-14-2003 10:55 AM

This error message bugged me too, with a CVS build of k3b not long ago.

What I did was enable scsi emulation for ALL of my optical devices, even if they are only "reader" devices.

The error message there is fairly descriptive. You need to pass the "hd[i]x[/]=ide-scsi" for all your optical drives, just like you did with your burner.

for eg, my /etc/lilo.conf has
Code:

append="hdc=ide-scsi hdd=ide-scsi"
even though only one of these is a CD burner.

This is assuming they are not actual SCSI in the first place. If you have IDE optical devices, many people I've spoken to recommend enabling ide-scsi for all of them.

This should remove your error message. :)



All times are GMT -5. The time now is 09:08 PM.