-   Linux - Hardware (
-   -   Joysticks registered as hdraw after update (

päse 06-08-2009 02:13 AM

[solved] Joysticks registered as hidraw after update
Hi folks

I recently updated my whole box because i moved my place and wanted to start over because i hadn't updated it for a time.

So, i reinstalled everything. Made my kernel (old was 2.6.26-r5, new is 2.6.29-r5) and did the same thing for getting my gamepads to work. I compiled the whole USB support in and compiled the joystick related usb things as modules.

But it won't work. I don't get any devices when i plug in my gamepad. I also tried modprobe joydev but that hadn't helped but lsusb recognizes the usb gamepad.

After hacking around in my kernel i activated support for hdraw. After that, plugging in my gamepad gave me a /dev/hidraw* device but that's not helpful.

Anyone knows how to get this working again? I use a speedlink strike2, recognized as "GreenAsia inc." (lsusb).

Thanks for any hints!

päse 06-10-2009 01:29 AM

Okay, lsmod says joydev is loaded. udev also recognizes my gamepad as low speed usb device and uses uhci_hcd. The matter is in udev i think, because when plugging in the pad it also says

Put GreenAsia Inc. joystick as /devices/pci0000:00/0000:00:1d.0/usb1/.......

but no /dev/js*

päse 06-11-2009 01:44 AM

Solved. Had to copy the standard udev ruleset and edit the rule

All times are GMT -5. The time now is 09:09 PM.