-   Linux - Hardware (
-   -   Issues booting USB from ASUS p8z68-m (

litedrive 02-17-2012 07:28 PM

Issues booting USB from ASUS p8z68-m
I am without a CD or DVD drive in my tower, else I would be using this instead. As far as using a USB drive, it works fine, however when I try to boot from UEFI, all that happens is my screen goes blank and, if I'm lucky, it just reboots. Otherwise, I have to restart the computer manually.

I JUST bought this custom tower, and was able to boot a different USB fine (with Windows 7), though the USB was my friends so I don't have access to it anymore. When I boot straight from the USB (i.e., without UEFI), I wind up getting a bunch of "Asking cache for write data failed" errors, and then it just stagnates at that. The initial splash screen loads fine, but that's the best if anything. I've tested this drive on my laptop and it works perfectly fine without any issues. Is there any hope at all for this? Is my 4gb usb drive considered obsolete with my motherboard? Should I use my external HDD instead? If possible, I'd like to just boot off of the USB.

Note: the version I'm trying to install is Ubuntu 11.10.

camorri 02-18-2012 08:50 AM

Have you gone into the BIOS and set the boot options to boot from USB before the hard drive, or any other boot source?

litedrive 02-18-2012 05:57 PM

Yup. I've tried many, many different things, including disabling SATA altogether. I eventually tried Wubi, which will install, but, as soon as it finishes it just leaves me with a blank screen and that's it. I have no idea what to do - I keep hearing something about "disable ASmedia SATA controller in the BIOS", which I may have done, but I have no idea what or where that would be, along with the fact that Google hasn't brought anything up.

Honestly, I don't think I'll ever buy an ASUS Mobo ever again.

litedrive 02-18-2012 07:38 PM

I should probably note that the only to get WUBI to install was via using the "ACHI Workaround" setting which existed.

camorri 02-19-2012 08:48 AM

Have a look at this link, this should work with current versions of Ubuntu as well.


You have to get a CD or DVD for the version of Ubuntu you want to install, I know you don't have one on the system you are installing on.

harry8227 06-01-2012 01:18 PM

I just spent an hour going in circles with Asus regarding Linux and the P8Z68-MPro motherboard and linux. They finally informed me that this motherboard does not support Linux. Doesn't mean we cant get it to work, just means they are not going to help. I could get Ubuntu 10-10 to load higher versions crash as do most other types in one fashion or another.

camorri 06-01-2012 02:24 PM


They finally informed me that this motherboard does not support Linux.
That is a bunch of crap. If it will boot a windbloze system, it will boot linux. There thousands of people running linux an Asus systems. No dought, they won't help you, even though you are their ( or were ) customer.

All times are GMT -5. The time now is 09:21 AM.