LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Issue with wake on USB (http://www.linuxquestions.org/questions/showthread.php?t=4175483491)

kelvinsu 11-05-2013 01:35 PM

Issue with wake on USB
 
Hi guys, first post here and wondering if you guys can help me out. I'm pretty bad with linux so you'll have to bear with me. I can get around the command line, and follow instructions from different forums etc, but that's about as much as I can do.

My hardware is a Gigabyte Brix i3 and I am running OpenElec (custom linux distribution for XBMC)on it. I have spent hours and hours trying to get the computer to wake from USB with no luck. Hoping to get some help here.

So from what I've read, I understand I have to make sure wakeup is enabled in two places.

1) /sys/bus/usb/devices/XXX/power/wakeup
2) /cat/acpi/wakeup

So first i run lsusb:
[CODElsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 046d:c043 Logitech, Inc. MX320/MX400 Laser Mouse
Bus 003 Device 005: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
][/CODE]

And i see that my keyboard has a product ID of "00db". To find the correct path:
Code:

grep 00db /sys/bus/usb/devices/*/idProduct
/sys/bus/usb/devices/3-2/idProduct:00db

I go ahead and check the mouse as well:
Code:

grep c043 /sys/bus/usb/devices/*/idProduct
/sys/bus/usb/devices/3-1/idProduct:c043

I check to see the power/wakeup state in both:

Code:

cat /sys/bus/usb/devices/3-2/power/wakeup
enabled

Code:

cat /sys/bus/usb/devices/3-1/power/wakeup
enabled

Both are enabled, which I think is correct.

Then I think this is where I have a problem. I check /proc/acpi/wakeup

Code:

Device  S-state  Status  Sysfs node
P0P1      S4    *disabled
USB1      S3    *disabled
USB2      S3    *disabled
USB3      S3    *disabled
USB4      S3    *disabled
USB5      S3    *disabled
USB6      S3    *disabled
USB7      S3    *disabled
RP01      S4    *enabled  pci:0000:00:1c.0
PXSX      S4    *disabled
RP02      S4    *enabled  pci:0000:00:1c.1
PXSX      S4    *enabled  pci:0000:02:00.0
RP03      S4    *enabled  pci:0000:00:1c.2
PXSX      S4    *disabled  pci:0000:03:00.0
RP04      S4    *disabled
PXSX      S4    *disabled
RP05      S4    *disabled
PXSX      S4    *disabled
RP06      S4    *disabled
PXSX      S4    *disabled
RP07      S4    *disabled
PXSX      S4    *disabled
RP08      S4    *disabled
PXSX      S4    *disabled
PEG0      S4    *disabled
PEGP      S4    *disabled
PEG1      S4    *disabled
PEG2      S4    *disabled
PEG3      S4    *disabled
GLAN      S4    *disabled
EHC1      S4    *disabled  pci:0000:00:1d.0
EHC2      S4    *disabled  pci:0000:00:1a.0
XHC      S4    *enabled  pci:0000:00:14.0
HDEF      S4    *disabled  pci:0000:00:1b.0
PWRB      S4    *enabled

I can see that EHC1 and EHC2 are the USB controllers:

Code:

lspci|grep USB
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)

Also i see that USB1-USB7 are all disabled. And there is no sysfs node either under any of them. Is this correct? I'm thinking this is part of my problem.

So I don't really know what I'm doing here, just kind of trying everything.

Doing this I am able to enable both USB controllers.
Code:

echo ECH1> /proc/acpi/wakeup
echo ECH2> /proc/acpi/wakeup

But I cannot enable any of the USB1-USB7 devices. Nothing changes when i do this:

Code:

echo USB1 > /proc/acpi/wakeup



Have tried with quotes as well.

But /proc/acpi/wakeup shows no change. I cannot wake with the keyboard from pm-suspend, however i know S4 is hibernate. Nothing happens when i enter the command pm-hibernate.

Any help would be greatly appreciated!

camorri 11-06-2013 09:24 AM

You have to make changes in the BIOS according to Gigabytes web site. Here is a quote.

Quote:

Does it support Wake on LAN (WOL)?

Yes, it supports. Wake on LAN function is enabled by default, just make sure to disable [Erp Support] option in BIOS setting.
Products: GB-XM12-3227 (rev. 1.0)
Not sure what ERP is, you have to disable it for WOL to work. I don't see any mention of it in your post. Is it disabled?

kelvinsu 11-06-2013 11:24 AM

Quote:

Originally Posted by camorri (Post 5059430)
You have to make changes in the BIOS according to Gigabytes web site. Here is a quote.



Not sure what ERP is, you have to disable it for WOL to work. I don't see any mention of it in your post. Is it disabled?

My issue is with wake on USB, not wake on LAN. ERP is disabled nevertheless. There are no BIOS settings for wake on USB, the BIOS is really spartan on the Brix.


All times are GMT -5. The time now is 07:34 AM.