LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-16-2008, 11:49 AM   #1
cdb931
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Rep: Reputation: 0
Issue with 8600GT


Hi, I'm sort of new to Linux and I'm having a problem with my video card.

It won't go to the correct resolution. It doesn't even show up in the display options. I'm running Fedora Core 8.
I installed the new drivers supplied by NVIDIA. It ran into a couple problems, saying it had to use my kernel to compile (or something like that). It's also being very slow compared to windows. I'm trying to play world of warcraft, and the FPS I get sucks. It lags even with everything at its lowest settings.

Anyway I use an LDC 32' HDTV for a monitor. Without flickering it can go up to ~~1300x768 (13 something). But right now it only allows me to go to 1024x768.

My specs are AMD 6000+, 4 GB ram, 500 GB sata HD, 512 MB NVIDIA 8600GT.

This might have been posted somewhere else, of so sorry, I have intense ADD.
 
Old 01-17-2008, 05:05 AM   #2
sophkos
LQ Newbie
 
Registered: Jan 2008
Distribution: Fedora 7
Posts: 16

Rep: Reputation: 0
Was the installation successful? When you type
glxinfo | grep OpenGL
you see your card?
 
Old 01-17-2008, 08:01 AM   #3
MyHeartPumpsFreon
Member
 
Registered: Oct 2007
Location: The States, Florida
Distribution: Lonely Werewolf
Posts: 251

Rep: Reputation: 30
You probably just need the proprietary Nvidia drivers installed. You have to enable the Livna repository. Then you have to install the proprietary driver.

To enable the Livna repository (as root or sudo):
Code:
rpm -hiv http://rpm.livna.org/livna-release-8.rpm
then
Code:
rpm --import http://rpm.livna.org/RPM-LIVNA-GPG-KEY
Now you just need to install the Nvidia driver with
Code:
yum install kmod-nvidia
Just to be safe, do a reboot and enjoy.

Regards,

Brandon
 
Old 01-17-2008, 02:26 PM   #4
Macphersonb
LQ Newbie
 
Registered: Jan 2008
Posts: 9

Rep: Reputation: 0
Oh! Now again! but with suse!

I'm having the exact same problem, except instead of Fedora8, i'm running SuSe10.3

What would be the correct procedure to get an 8600GT (technically two of them in SLI, but i'm gonna ignore one) working with drivers?
 
Old 01-17-2008, 04:30 PM   #5
MyHeartPumpsFreon
Member
 
Registered: Oct 2007
Location: The States, Florida
Distribution: Lonely Werewolf
Posts: 251

Rep: Reputation: 30
Mac,

Please read this how-to for installing the driver for your video card. It's Suse specific. http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html

After you've skimmed over that, download the driver from here and install http://www.nvidia.com/object/linux_d...32_169.07.html

Regards,

Brandon
 
Old 01-18-2008, 01:21 PM   #6
cdb931
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
It isn't working. The resolution doesn't show up unless I hit CTRL + ALT + F1 and then type system-display-config.. Then it shows up there. Also once I set the resolution there, it works. But once I type init to get back into the gui, the resolution sets back to the cheap mode and I don't get my wide screen, and it isn't in the display config either. I'm on a LCD 32 inch HDTV, and I set the resolution to 1368x768 (or something like that).
What I did so far was install the NVIDIA drivers from the web site by following their instructions. Then I followed the instructions on the forum.

Thanks for your help!
 
Old 01-18-2008, 01:47 PM   #7
MyHeartPumpsFreon
Member
 
Registered: Oct 2007
Location: The States, Florida
Distribution: Lonely Werewolf
Posts: 251

Rep: Reputation: 30
CDB,

You don't need to download the drivers from the Nvidia website. If you follow what I said a few posts ago about enabling the Livna repository, then run the command
Code:
yum install kmod-nvidia
this will install the Nvidia drivers for you. Thus giving you the resolution of 1368x768 (I have the same setup as you with the TV and almost the same card. I have an 8500, and am running Fedora 8).

Yum will install everything for you and will set it to the optimum configuration.

Regards,

Brandon
 
Old 01-18-2008, 08:26 PM   #8
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
Unless you are having issues with livna-config-display which continues to mess up all my settings. I removed livnas kmod-nvidia and went for the newest beta drivers.

To setup a custom resolution, you will need the horizontal sync and vertical refresh rates.

Then it is just a matter of playing with "/etc/X11/xorg.conf" .

Part of my own xorg.conf (the bits you need).

Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor 1280x1024"
        HorizSync    31.5 - 79.0
        VertRefresh  50.0 - 90.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "nVidia Corporation Unknown device 01df"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1152x864_75" "1024x768_85"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1152x864_75" "1024x768_85"
        EndSubSection
EndSection
Ok, to hopefully get your custom mode working, change the screen section to look like this.

Also change the Vertical Refresh and Horizontal Sync Rates to match whatever your tv uses.

Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor 1280x1024"
        HorizSync    31.5 - 79.0
        VertRefresh  50.0 - 90.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "nVidia Corporation Unknown device 01df"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1300x768_75" "1024x768_75"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1300x768_75" "1024x768_75"
        EndSubSection
EndSection
Try that and see if it helps.

Last edited by v00d00101; 01-18-2008 at 08:30 PM.
 
Old 01-21-2008, 05:46 PM   #9
cdb931
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, so if I do this right, will it run games as well as Windows would? I'd hate running back to windows every time I want to play a game. I'm using Wine to run my games so far. Hopefully that's the best option.

Update: I got the resolution to work about half the time. It's weird, it might be due to me installing the nvidia drivers I got off the site, and these drivers. I get the Nvidia software to edit the xorg.conf for me. I think I should completely remove all of the drivers and start up again with what you said, but I don't know how without just formatting.

Last edited by cdb931; 01-21-2008 at 05:47 PM.
 
Old 03-29-2008, 05:41 PM   #10
Fergatron
LQ Newbie
 
Registered: Apr 2005
Location: Georgia, USA
Distribution: Fedora 12
Posts: 25

Rep: Reputation: 15
I'm having problems with my nVidia 8600 aswell. I got kmod-nvidia installed and now it simply shows me a square pixelated icon. I hear a sound, but nothing else. Do I need to do anything with the Config.wtf file. I'm running Fedora 8, thanks.
 
Old 03-29-2008, 10:28 PM   #11
Doug52392
Member
 
Registered: Jul 2007
Distribution: Fedora 7, Ubuntu 7.04
Posts: 34

Rep: Reputation: 15
I used to have the same exact issue when I hooked up my nVidia 8600GT on a Fedora 7 system.

Using Livna's nvida driver fixed it.
 
Old 03-30-2008, 12:42 AM   #12
Fergatron
LQ Newbie
 
Registered: Apr 2005
Location: Georgia, USA
Distribution: Fedora 12
Posts: 25

Rep: Reputation: 15
See the problem is I installed Livna's drivers using:
Code:
yum install kmod-nvidia
I don't get the nVidia splash screen when I log in, but I do see that it replaced my driver I had before. I'm still getting the same problem. If I switch to enable opengl, then I get a 3d accelerator error. ???
 
Old 03-30-2008, 04:04 AM   #13
cdb931
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
Yeah I got it. It has something to do with the "phase" setting in my monitor... yet I know nothing about it. What I do know is when I encounter the problem, I set tbe monitor to go with auto settings. And the only number I see change is the "phase" value. Anyway


Thanks for your help guys. My video card works perfect on linux now. *pardon my french* but FUCK windows. Later guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: ASUS GeForce 8600GT 256MB On Linux LXer Syndicated Linux News 0 10-30-2007 03:10 AM
nvidia 8600GT drivers ekj Linux - Hardware 2 09-23-2007 05:49 PM
SuSE10.2 networking issue Inter. connect. issue LVSuSE Linux - Networking 3 08-31-2007 02:42 AM
which distro will support my new Nvidia 8600gt video card? lenny45 Linux - Software 12 07-27-2007 04:42 PM
LXer: Gigabyte GeForce 8600GT 256MB On Linux LXer Syndicated Linux News 0 07-26-2007 09:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration