LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Is DMA mode enabled for my optical drive? (http://www.linuxquestions.org/questions/showthread.php?t=4175436482)

stf92 11-09-2012 06:58 PM

Is DMA mode enabled for my optical drive?
 
Hi:

In an attempt to know if my optical drive /dev/hdc has DMA mode enabled, I ran
Code:

$ sudo /usr/sbin/hdparm -I /dev/hdc

/dev/hdc:

ATAPI CD-ROM, with removable media
        Model Number:      PHILIPS SPD2417T                       
        Serial Number:     
        Firmware Revision:  P1.0   
Standards:
        Supported: CD-ROM ATAPI-3 -4 -5 -6 -7
Configuration:
        DRQ response: 50us.
        Packet size: 12 bytes
Capabilities:
        LBA, IORDY(cannot be disabled)
        DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4
            Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4
            Cycle time: no flow control=383ns  IORDY flow control=120ns
$

but this does not seem to give the information I seek. Does somebody know how to get it? Perhaps /sbin/dmesg|grep some_string? BIOS setup menu does not mention DMA, except for the parallel port.

EDIT:
I also tried this:
Code:

root@darkstar:~# dmesg|grep hdc|grep DMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:DMA
hdc: ATAPI 16X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(66)
root@darkstar:~#

Does it mean that optical drive has DMA mode enabled? I do not think so.

macemoneta 11-10-2012 12:28 AM

Yes, you are using DMA, specifically udma4. The asterisk next to the mode in the first response indicates the mode in use.

stf92 11-10-2012 12:36 AM

Yes, I came to that conclusion when I saw the asterisk later. But even so I was not sure. Thanks a lot.


All times are GMT -5. The time now is 06:46 AM.