LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   iPOD with Rockbox and Amarok on Ubuntu (https://www.linuxquestions.org/questions/linux-hardware-18/ipod-with-rockbox-and-amarok-on-ubuntu-602145/)

skr 11-24-2007 05:12 PM

iPOD with Rockbox and Amarok on Ubuntu
 
Rhythmbox kept crashing as soon as I connected my iPod so I thought I'd change my setup.

Now I have an iPOD Photo running Rockbox and am using Amarok on Ubuntu.
Amarok recognises all my music collection and I can add files to the Transefer Queue but when I click on 'connect' get the error message:
No Media Device: No mounted iPod found.

The iPod is recognised on the desktop but the Properties do not have entries against:
Mount Point
File System
Mount Options

Amarok Settings, Media Devices list two devices:
My IP [Which I think I have added manually]
Autodected: No
ID: Manual My IP
Name: My IP
User Label: (none)
Device Node: (none)
Mount Point: /dev/sdf2 [I entered this based upon the information below]
Mime Type: (none)

Plugin: Apple iPod Media Device

sfd2 [created automatically]
Autodected: Yes
ID: /org/freedesktop/Hal/devices/Volume_uuid_8BDA_9DBE
Name: sdf2
Label: My IP
User Label: (none)
Device Node: /dev/sdf2
Mount Point: (none)
Mime Type: media/removable_unmounted

Opened up a terminal:
Mount /dev/sdf2
mount: according to mtab, /dev/sdf2 is already mounted on /media/MY IP
mount failed

To check if the issue is with Amarok or the iPod I reinstalled Rhythmbox but this still crashes as soon an my iPod is connected.
Any assistance appreciated.

Simon Bridge 11-24-2007 11:04 PM

Sell ipod and buy real media player.

mount: according to mtab, /dev/sdf2 is already mounted on /media/MY IP

mkdir /media/ipod
umount /dev/sdf2
mount /dev/sdf2 /media/ipod
ls /media/ipod

Is it there?

You probably want something like this:

sfd2 [created automatically]
Autodected: Yes
ID: /org/freedesktop/Hal/devices/Volume_uuid_8BDA_9DBE
Name: sdf2
Label: ipod
User Label: My IP
Device Node: /dev/sdf2
Mount Point: /media/ipod
Mime Type: media/removable_unmounted

... if I've understood correctly. For existing setup, probably need to exchange "ipod" for "MY IP" (is that space really an underscore though?)

skr 11-29-2007 03:34 PM

I take your point regarding a real media player, I have had the ipod for years, since way back when I also used an operating system called windows.

Seriously Simon, thanks all is working now.
(What would you class as a real media player ?)


All times are GMT -5. The time now is 06:06 AM.