-   Linux - Hardware (
-   -   iPod Nano 5th Generation: gtkpod/libgpod problems (

thegoofeedude 01-16-2011 01:51 PM

iPod Nano 5th Generation: gtkpod/libgpod problems
Hi guys,

I've been trying to get an iPod nano 5th generation working with slackware-current, with no luck. Currently, I have upgraded to gtkpod 1.0.0 and libgpod 0.8.0. I've run ipod-read-sysinfo-extended successfully, which wrote the SysInfoExtended file in /<ipod_root>/iPod_Control/Device.

After those steps, gtkpod would copy the mp3's to the device, but would fail writing the database. So, I generated the HashInfo file from the firewire guid using the tool at

After that, gtkpod finishes writing the database to the device, and shows all the music which is present, but after ejecting the iPod, no music shows up.

Anyone else had any luck with the iPod Nano 5th generation and libgpod/gtkpod?

TheIndependentAquarius 01-17-2011 11:02 PM

Gtkpod doesn't yet support the 5th gen Ipod nano:

jollyDirge 01-18-2011 06:45 AM

Also using 5th gen nano and running Gentoo.

Have gtkpod 1.0.0 and libgpod 0.8.0. I followed the same process as thegoofeedude with the same result. However I've found if I plug the ipod into a windows PC with itunes and simply eject the ipod as soon as itunes recognises it, everything loaded using gtkpod becomes accessible and the song and podcast counts change from zero the correct values.

If plug into gtkpod and change anything then after I eject the Ipod the counts have returned to zero and the file are unavailable again until I once again plug into itunes and eject the iPod.

thegoofeedude 01-18-2011 10:05 AM

Thanks Anisha,

I had read reports of people getting it working (after first syncing with iTunes, subsequent uses of gtkpod worked for some people,) but it seemed flaky. The release notes indicate that libgpod 0.8.0 does support the 5g nano (as reported by .) I think I'll contact the developers to see if there are configuration issues on my end preventing it from working.

Thanks again for your reply!

TheIndependentAquarius 01-18-2011 10:20 AM

That link talks about 6g not 5g. You might like to shoot them on their mailing lists:

Anyway, if you get this working do not forget to post the solution here :)

Efo 06-17-2011 01:00 AM

Hi guys,

I have the same device and similar issue.
I tried gtkpod-2.0.0 but no luck, I keep getting:
"Failed to generate sqlite database: an error occurred during Locations.itdb.cbk generation"

It looks like libgpod 0.8.0 supports the nano 5g; gtkpod recognizes the device when it didnt with older libraries.

thegoofeedude: did you get it working?

Any help or info is highly appreciated, does anybody have ipod nano 5G working on linux?



thegoofeedude 06-18-2011 01:40 PM

Hi Efo,

I have not gotten it working yet. I do plan on working on this in the coming weeks (I no longer have access to machine I was originally testing on, and I need to upgrade my remaining machines to try again.)

I'll definitely post here with results if I get it working.

Efo 06-19-2011 02:36 AM

Hi thegoofeedude,

Thanks for the reply,I am looking forward to some good news :)
If I find something relevant I will post it as well.

Efo 08-21-2011 06:54 PM

Hi all,

I think I got gtkpod working with my iPod Nano 5th Generation.
Not sure what did it, but I reset the device with iTunes (windows) and followed the instruction posted by thegoofeedude in the first post.

I added the songs using gtkpod; even though the songs were added to the iPod, gtkpod wouldnt show them. So I followed the suggestion by jollyDirge: plugged the ipod in a windows machine with iTunes => open iTunes => eject the iPod => plugged it back into my Linux box; and everything was there. Now it works without needing iTunes anymore.

One thing I noticed is that if you generate a playlist in the "Music Library" and then you copy it to the iPod, you lose your artwork. However, if you generate the playlist directly on the iPod the artwork is preserved. Also, when you want to copy a playlist from the "Music Library" to the iPod, you have to right click on the playlist => "Copy selected playlist to.." => ... (dragging the playlist doesnt work).

I am using the following versions:

I tried gtkpod-2.0.0 and 2.0.2, but these versions didnt allow me to copy m4a on the iPod.

thegoofeedude 08-29-2011 09:08 PM

Hi Efo,

Thanks for your update! I'm glad you successfully got it working.

I'm sad to say I did not. The iPod in question was my dad's and he decided to switch back to Windows instead of fiddling with it! I just didn't have the time to track down the solution for a few months, so he gave up waiting.

Just a heads up for future readers of the thread.

pwhalen 11-20-2011 11:36 PM

Worked for me
Thanks guys, attempted to get my ipod working a few months back with no success, thought I would try it again and it worked using the steps above. I'm on Fedora 15.

All times are GMT -5. The time now is 11:46 PM.