-   Linux - Hardware (
-   -   ipod mini and gtkpod-0.99.2 (

buffed317 12-31-2005 02:49 PM

ipod mini and gtkpod-0.99.2
I am having trouble installing gtkpod. I installed libgpod-0.3.0 beforehand but get this message.

checking for gcc option to accept ANSI C... none needed
checking for pkg-config... ok
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for PACKAGE_CFLAGS...
checking for PACKAGE_LIBS...
Package libgpod-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgpod-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgpod-1.0' found
configure: error: ***
See `config.log' for more details.

i have tried looking for libgpod-1.0 on google and sourceforge and cant find it. any suggestions?

chandan 01-01-2006 01:45 PM

I am using FC2. Please ignore if it is irrelevant to slackware.

I tried compiling gtkpod and failed to satisfy all the required dependencies. I ended up installing gtkpod-0.94.0-1.1.fc2.rf from an rpm.
I had to install the following rpms:-
1. faad2-2.0-0.lvn.0.2.rc1.2.i586.rpm
2. gtkpod-0.94.0-1.1.fc2.rf.i386.rpm will may help you install and use rpm on a slackware system.

buffed317 01-10-2006 03:30 PM

i did something similar for slackware. i used an earlier version with libgpod included in the package.

eduardo451 01-17-2006 10:01 PM

Have you tried looking for libgpod-1.0.pc on your computer? It may be gtkpod just can't find it. I just encountered this issue with the cvs versions. It turned out that libgpod-1.0.pc was in /usr/local/lib/pkgconfig instead of /usr/lib/pkgconfig. I copied it over and gtkpod installed fine.

All times are GMT -5. The time now is 05:56 PM.