LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Invalid Partition Map w/ Kernel Panic (https://www.linuxquestions.org/questions/linux-hardware-18/invalid-partition-map-w-kernel-panic-93868/)

Vellos 09-17-2003 02:14 PM

Invalid Partition Map w/ Kernel Panic
 
I've recently run into a nasty problem that I can't fix no matter how long I try.

I've got two hard drives that have acting up. One 1.6GB Western Digital Caviar and an 850MB Conner HD. Both are giving me problems under just about any distribution I try, even Windows cries foul.

When trying VectorLinux, I am able to get to the partition program CFDISK. Upon loading it, it gives me the error "Invalid Partition Table" or occasionally "Volume mounted read-only" or some such thing, usually the first of the two. So I can't touch the drive with CFDISK.

I try another distro, Slackware. It starts to set up almost about to install, then when it tries to mount the HD, BAM, kernel panic with a crapload of hex code spewing out. This happens on both disk in any distro other than VectorLinux.

I tried to zero the drives after looking around for some help. I put one of the drives into slave mode and hooked it up to my Mandrake box, so I could dd if=/dev/zero of=/dev/hd* it. No such luck, it paniced as well on boot.

I tried using DOS tools to fix them. I forged a boot floppy with FDISK and ZEROFILL to help. FDISK was able to write partitions that I could format in DOS (via FORMAT C:), but Window's installer would crash upon trying to load drivers for all the devices in the install. DragonLinux, which will run in FAT16/32, also panicked on the partition made for it.

I'm at a loss here, and my last resort seems to be attempting a low-level format of the drives. Although, if they're screwed, I can get new ones. Previous OSes and Linux distros worked fine on them. I just tried to format them in CFDISK for ReiserFS and then they died, both of them.

Anyone got any ideas?

The system I'm trying to install on:
P5-100 Tower
100Mhz Pentium Pro (socket 7)
56MB of RAM (EDO)
S3 Trio64 2MB PCI video card
(Unknown Brand) IDE CD-ROM drive, 4x speed
Linksys 10/100BT Ethernet PCI card
Nothing else other than a keyboard and mouse, PS/2

I know it's old, but it'll make a good machine under Slackware.

J.W. 09-17-2003 03:42 PM

I'm no expert but it sounds to me like they're hosed. If you've got them jumpered properly, and they barf with any OS you try, it sure sounds like a hardware problem to me.

However, even if you could get them to work, would you have any confidence that they'd be stable and reliable in the future? If I were in your shoes, I'd say No. Personally, you might just want to buy yourself some peace of mind and buy some new disks. (Also does the machine really only have 56M of memory? Wow - you might want to upgrade that too) -- J.W.

Vellos 09-17-2003 04:03 PM

Hmm, that's what I thought.

They're old drives, I can get newer, bigger, and faster ones for cheap (don't need much, Slackware runs well on older systems, this one did well when it was running).

They DO, however, run well when formatted on a Mac. Hmm, I could take the Quantum from my old Performa and put the Western Digital in that.

Well, I guess I can safely say I have a nice pair of paperweights.

As for the RAM, Slackware recommends anywhere from 32MB to 64MB of RAM for a Window Manager to be used. I've used IceWM (my preference) and it ran very well when I only had 48MB of RAM on it (even without a swap partition, I rushed though the Vector install and *sorta* forgot to make a swap partition, probably made a swap file somewhere on the root of the drive).


All times are GMT -5. The time now is 10:14 PM.