-   Linux - Hardware (
-   -   internet connection and sound gone after recovering from suspend. (

BobAppleby 02-01-2012 03:15 PM

internet connection and sound gone after recovering from suspend.
My HP desktop has been working fine for over a year. using a wired connection, but often over the last couple
of weeks, when returning from suspend, the internet is not active and the sound is gone. Reboot is necessary in order to get them back. Before the the reboot the internet icon is gone and the sound icon is grayed out. Any ideas?

Ion Silverbolt 02-02-2012 12:09 AM

Any recent changes done to the system when this started? Sometimes something simple as leaving a usb drive plugged in, or a flash memory card can cause issues. Which it shouldn't, but it might be a contributing factor.

Have you tried to manually remove and reload the modules for sound and network?

Is there any output from dmesg after you wake from suspend?

SecretCode 02-02-2012 03:45 AM

If you disable networking, then suspend, then resume, can you re-enable networking and get online? If this works, it would suggest a power management issue (could have been introduced in just about any update) which we might be able to work around.

BobAppleby 02-03-2012 09:01 AM

I changed either the power or screen settings recently. Don't remember what the original settings were, so I changed several things with no improvement in the problem. How does one "manually remove and reload the modules for sound and network"? No output from dmesg noticed.

Disabling the networking and then going to suspend worked sometimes and sometimes not.

I noticed the following in the past couple of weeks: 1. When returning from suspend with network not operating, when the power icon is clicked it yields a greyout and refuses to work. 2. When returning from suspend the screen remains dark until the space bar is hit which was not required before.

What about simply reloading ubuntu, might that not work? Apparently the problem is not in the computer as Windows (used only for Netflix) works fine.

I really appreciate the help you guys are giving.


All times are GMT -5. The time now is 10:54 PM.