LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-03-2004, 10:34 PM   #1
perryub
Member
 
Registered: Apr 2004
Location: Ontario, Canada
Distribution: Ubuntu Hoary
Posts: 45

Rep: Reputation: 15
interesting problem with ALSA


Hi,

I did some searching and tried a few different things, none of which have alleviated my problems. My system is a P4 1.5Ghz w/512MB RAM with a Soundblaster Live! sound card running Mandrake 9.2. I noticed that when I play MP3's using XMMS, the audio is choppy and filled with static. At first, I thought I downloaded a lousy copy of the song, but the same holds true even if I burn the song myself. When I play CD's using KsCD, everything sounds perfect until I almost max out the volume. The driver I'm using is snd-emu10k1.

I tried muting the "SB live digital/audio jack" - with absolutely no effect. Any ideas?

Thanks,

Perry
 
Old 06-04-2004, 02:30 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Change the XMMS output plugin from OSS to ALSA or ARTS-- right-click the XMMS window, Options=>Preferences=>Output plugin. You may want to configure the plugin as well.

Don't max out your volume; or lower the mixer volume (PCM, CD) in KMix or alsamixer before raising the KsCD volume (or vice-versa). Maxing out volume controls in the mixer tends to result in distorted sound. 70-80% is usually considered optimal.

Hope this helps.
 
Old 06-04-2004, 04:36 AM   #3
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
Also, the volume control on the main xmms window actually controls the PCM channel fader. If you have this turned up then the sound will saturate (or at least it does on my notebook's sis7012 sound controller). I find if I set it to 80% then it's OK.

If the sound is actually cutting out momentarily then you are getting buffer underruns. You should increase the size of your sound output buffer. There should be an option for this somewhere in the xmms/output plugin settings.
 
Old 06-04-2004, 07:48 AM   #4
perryub
Member
 
Registered: Apr 2004
Location: Ontario, Canada
Distribution: Ubuntu Hoary
Posts: 45

Original Poster
Rep: Reputation: 15
Thank you to the posters - while I have tried both suggestions, the sound quality is still awful. The only thing that can describe it accurately is AM radio in a tunnel during a thunderstorm! Play a CD and it is pitch perfect. I'm at a loss.

Perry
 
Old 06-04-2004, 08:00 AM   #5
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
If CDs play fine, but other kinds of music don't then you probably want to configure the input plugins for the kind of files that don't sound right.

Right-click the XMMS window, choose Preferences=>Options and select the input plugin for the affected type of music file and click the Configure button. You might also want to click the Configure button for the Output Plugin in the lower half of the window as well.

Sometimes the default settings aren't good enough.
 
Old 06-04-2004, 10:40 AM   #6
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
Are you playing your cds using xmms at all? If you're using a cd player application like kscd or similar then the sound is not going through the pcm channel at all but rather through a dedicated channel your sound controller has for cd output (that's why the cd has its own fader on the mixer). There is a wire that connects the cd drive to the sound controller for this purpose.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Interesting Video Problem with ATI Radeon 9800 Pro (not a 3D accel based problem) binarynova Linux - Hardware 1 08-27-2005 10:49 PM
An interesting soundcard problem endfx Slackware 2 12-15-2004 12:38 PM
An interesting problem about C++ zyzyis Programming 4 10-11-2004 03:38 PM
an interesting problem dlpmdr Linux - Distributions 2 03-30-2003 01:47 AM
An interesting partitioning problem.. concoran Linux - General 1 01-09-2002 01:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration