-   Linux - Hardware (
-   -   Intel X3100 graphics intermittent fault? (

Flymo 08-19-2009 08:03 AM

Intel X3100 graphics intermittent fault?
This is an annoying thing where at any time at all the screen goes white - or nearly white, with no graphics, text or cursor.
Machine is an ACER 4315 laptop with Celeron 540 and 2G RAM, feels a bit warm to the touch, but temps reported are around 45 to 50 degrees max.
Workaround is to restart X (CTRL-backspace) which usually works in that the screen can come back as X restarts. More reliable and less traumatic is to use CTRL-ALT-F1 to get a terminal, followed by CTRL-ALT-F7 to restore the X screen.
Wrestling with the Intel data does not (so far) reveal any obvious reason why this would happen, unless it is just getting hot and flaky?
Any suggestions? Anybody else seen this?
It does seem to happen more and more often with passing time, so it would probably be good to find and fix this.... <grin>
Best regards, and thanks in advance, Ben

Flymo 08-24-2009 02:55 AM


Flymo 10-11-2009 04:06 AM

OK - we are getting an association with the laptop lid being moved up or down. Might be a bad contact in or near the hinges?
Anybody seen that on one of these Acers?

Closing the lid all the way (or using the appropriate function key) to invoke Hibernate in (eg) Ubuntu 8.04.3 LTS then letting it settle down before hitting the keyboard to restore the session often clears the fault.

The Problem is consistent regardless of OS.

This laptop has Ubu 804, Xubu 904, PCLOS 2009, Zenwalk and the Ubu 910 Beta all on the hard drive, accessible via GRUB. Same problem and similar solutions with all of them. It is also used to test varii Live CDs and DVDs from time to time, same problem/workarounds apply. <sigh>

Any ideas folks? Will prise it all open one day, after we have another machine up and running, probably on Ubu/Xubu 910 once it goes final and we have all the home folder transferred and running cleanly.

All the best, Ben

Flymo 07-19-2010 05:12 PM

Finally fixed it!
No-brainer really, pulled it apart, found the cable bundle leading from base to screen, and fiddled with it. Been good ever since.

Found someone with the same problem on YouTube here

All I needed to do was pop off the cover that goes between keyboard and screen pivots, and there by the left pivot was the cable bundle - I just rearranged it a bit, and all was OK.

Marking this as SOLVED now!

All the best, Ben

All times are GMT -5. The time now is 09:31 PM.