LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Intel Pro Wireless 2200 (https://www.linuxquestions.org/questions/linux-hardware-18/intel-pro-wireless-2200-a-387139/)

lokirulez 11-27-2005 11:02 PM

Intel Pro Wireless 2200
 
I recently installed the ipw2200 drivers I downloaded from http://ipw2200.sourceforge.net/. I installed the ieee80211 drivers as well along with the firmware and wireless tools. I had no errors and was able to execute modprobe ipw2200. When I run iwconfig I get the following output:
Code:

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      radio off  ESSID: off/any
          Mode:Managed  Channel: 0  Access Point: 00:00:00:00:00:00
          Bit Rate=0 kb/s  Tx-Power=off
          Retry limit:7  RTS thr: off  Fragment thr: off
          Encryption key: off
          Power Management: on
          Link Quality:0  Signal level:0  Noise level: 0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag: 0
          Tx excessive retries:0  Invalid misc:0  Missed beacon: 0

eth2      no wireless extensions.

sit0      no wireless extensions.

I'm not sure if that is what my output should look like. When I tried to use the kwifimanager to connect to my local wireless network, it says scan complete, no networks were found. I know this is wrong because there is a wireless network available that my friend can connect to with MS Windows. Did I miss a step? Is my wireless card even working? Any suggestions?

cyberjun 11-28-2005 01:40 AM

Hi,
Your output says "radio off". Are you sure you have switched on the hardware switch on your machine for wireless?

Have a look at /var/log/messages file for output of modprobe.

Cheers,
--cyberjun

lokirulez 11-28-2005 01:43 AM

I did notice that, but I do not know how to turn the radio on. My wireless card is internal.

cyberjun 11-28-2005 05:04 AM

Hi,
There must be some switch on your laptop(Am assuming its a laltop). Sometimes its a Fn+<some key>. Look for some green/gray coloured text/icons on your keyboard.

What is the machine config by the way. Are you sure ipw2200 is the right driver for you? It generally works for centrino based machines.
What is the output of ifconfig eth1? Do you get a HWAddr in there???


Cheers,
--cyberjun

lokirulez 11-29-2005 03:38 AM

You were right, the FN button and F2 enabled my card. I didn't even thing to try it, I assumed it would not work. I guess I have learned to try everything no matter how simple it may seem.

lokirulez 11-30-2005 02:01 AM

WHY IN WINDOWS BUT NOT DEBIAN?
 
Yesterday when I was able to connect I was at place that offers free wireless services. I had an excellent signal. Today I tried connecting to a local wireless network where I live and had no luck. I know the network is up because my friend has a laptop as well, except that he is running Windows. His laptop detects the network and he is able to connect. I know my card works because I used it yesterday, nothing has changed, except the location. Could it be that I am not using the full potential of my card...in terms of range or something?

cyberjun 11-30-2005 03:54 AM

Hi,
Unlike windows you ought to configure your connection for each network. How did you configure the network before ?
You can download and use wifi-radar if you prefer simpler life. Sorry I don't know what tools debian provides. I use Gentoo and I use iwlist, iwconfig utilities to scan and configure wireless network.

Also, your local wireless network might not be free and some kind of WEP key might be involved. And I really can't guess what "unable to connect" would mean :D . So please detail the procedure you are using to connect to the network and have a look at wifi-radar. Its quite similar to the windows wireless config manager.

good luck!

--cyberjun

lobwolf 12-05-2005 07:48 PM

SSID name
 
That happened to me as well and because the wireless network SSID was different, so go to the connection properties in the "network" option, select your wireless connection and change the SSID name. Hope this works.


All times are GMT -5. The time now is 02:00 PM.