-   Linux - Hardware (
-   -   Intel Pro 100M Integrated PCI NIC Card with Fedora Core 5 (

Babar1082 07-19-2006 09:59 PM

Intel Pro 100M Integrated PCI NIC Card with Fedora Core 5

Newbie to Linux having trouble settin up my NIC card in any distribution of Linux.

I have a Dell Dimmension 4550 with an Inntel Pro 100M Integrated PCI NIC Card and am running Fedora Core 5 (2.6.15-1.2054).

So basically I have researched the hell out of this topic on various forums to no success; I finally made some progress today but am still stuck. Any help would be much appreciated.

So in Fedora under Administraion>Network it says that I have an Intel Corporation 82801DV PRO/100 VE (LOM) Ethernet Controller. I am not sure if this is correct. All I know is that on my shipping package it says that I have an "Intel Pro 100M Integrated PCI NIC Card". Thinking that the driver is in fact wrong, I went and downloaded the appropriate driver from Intel at their site.

It is basically the Linux* 10/100 Adapter Base Driver [e100-3.5.14.tar.gz].

I tried to install the driver as root but it complained that it didn't have the Linux source; I couldn't do a "make install". So after playing around for several hours, I figured out how to add the source through another site.

I issued the following commands after I moved the rpm over with a FLASH drive:

>rpm -ivh kernel-2.6.15-1.1955_FC5.src.rpm
>rpmbuild -bp --target=$(uname -m) /usr/src/redhat/SPECS/kernel-2.6.spec

I made sure the source and my current kernel are the same as suggested by several forums.
It still complained the linux source could not be found when I tried to do a "make install" on the Intel drivers. Eventually, I figured out I need the kernel headers as well, so I went ahead and downloaded that as well:

I issued the following command in regards to the kernel headers:

>rpm -ivh kernel-devel-2.6.15-1.2054_FC5.i686.rpm

This solved the problem of the "make install", "Linux source not found" I was experiencing with the Intel drivers. So basically I went to the directory for the Intel driver (e100-3.5.14) and then into its source directory and then issued the command:

>make install

It worked and made the object files and the e100.ko file. I then followed the Intel instructions and issued the following command:

>modprobe e100

I verified that the binary was installed in "/lib/modules/2.6.15-1.2054_FC5/kernel/drivers/net/e100/e100.ko"

My ethernet still doesn't work. When I go to Administration>Network in the KDE gui I can't select the driver. It wants to use the original one for some reason.

Now I am not clear as to what I need to do? Do I need to recompile the kernel? If so, how do I go about doing so in Fedora Core 5? I tried following instructions online, but I would receive errors and could not recompile the kernel.

If I don't need to recompile the kernel, does anyone have any idea what is wrong? What should I try doing?

I am very new to Linux, so as much detail as you can provide would be helpful. I tried to explain where I am up to in detail so that it would make it easier. Thanks in advance.

Babar1082 07-19-2006 10:47 PM

Some more info, when I set the driver to the e100 I installed, it reverts back to the original on "Intel Corporation 82801DE" after I restart. I am not sure why it is doing that? I set it through the KDE GUI app in Administration>Network.

All times are GMT -5. The time now is 08:51 AM.