LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Intel GM965 (X3100) Graphics Trouble (https://www.linuxquestions.org/questions/linux-hardware-18/intel-gm965-x3100-graphics-trouble-581381/)

poetic_assassin 08-31-2007 11:21 PM

Intel GM965 (X3100) Graphics Trouble
 
Greetings,

I've got a shiny new Sony VAIO FZ145E Laptop that came with oh-so-many nice features... except that it's default installation of Windows Vista was just begging to be replaced by a superior OS - namely SuSE 10.2, my OS of choice.

The problem:
Intel's new GM965 Graphics chipset does not play so nicely with current Linux distros I have found. I even tried Fedora 7, which I also like, but it won't even read the CD drive in the machine to install. In SuSe 10.2, the system sits in 800x600 resolution on the VESA Framebuffer driver; and won't let me change anything.

I've got a little experience compiling source code for hardware drivers, but not a lot. The Xorg 2D drivers on www.intellinuxgraphics.org reach a certain point and fail each time. The message I get is:

Code:

"configure: error: Must have X server >= 1.3 source tree for mode setting code."
Anyone run into this problem? Know where to go from here?

(P.S., if this belongs in the software section... my bad! I figured since it's about getting hardware to work it should go here)

GrueMaster 09-02-2007 10:53 AM

Check the Suse 10.3 repositories to see if they have a beta for this driver. I'm running Mandriva 2007 Spring Edition, and it was in a separate installation rpm. It works quite well, though.

It's not easy to build from the Intel site, as you need a later version of Xorg than what ships with most rpm based distro's.

PhantomLimb 09-10-2007 07:34 PM

I have exactly the same problem on my vaio laptop (running openSUSE 10.2). I got where you were and used the command:

git-clone git://anongit.freedesktop.org/git/xorg/xserver

That downloads the xserver source files. Then I did:

./configure --with-xserver-source=/path/to/xserver

After that it was just

make
make install

That got me past that error but I still can't switch to the new intel driver.

Hope this helps. If you get it working please let me know. I'll be working on it also.

centguy 02-17-2008 12:12 AM

It is rather unfortunate that I don't see many replies to the original "Intel GM965 (X3100) Graphics Trouble".
I have a Fujitsu Lifebook A6030 wide screen (i.e., 1280x800 with an aspect ratio of 1.6) two months ago. I am a fan of red hat
(I have used red hat 7.3, 9.0, centos 4.5) but even Centos 5.1 gives a default 800x600 resolution.
On Centos 5.1, even after I switch to the generic VESA driver, the best I can get is 1024x768, thus distorting my display. I read the instructions under intellinuxorg but the instructions are very high level (meaning hard to understand, even for someone who have used Linux for some many years).
It seems to me that to install the proper driver provided by intellinuxorg, then I have to upgrade Centos5.1 kernel
and the X server. This sounds rather scary (I don't have much time and energy for my scientific research!!)

Since I don't get much help, I have switched (after a friend's recommmendation)
to opensuse 10.3 after two weeks of late nights. Opensuse 10.3 "solved " my display problem, but it also means that I have to say goodbye to Centos and redhat. (BTW, I don't have much luck with Fedora either)

From time to time, I google search this problem and hope someone will give some hints so that I may do some
experiments on my WindowsXP+OpenSuse10.3+CentOS5.1 triboot system. Meantime, I am doing some reading and thinking about this important problem (at least to me!).

maroonbaboon 02-17-2008 08:23 AM

Just some background from a Debian perspective. There is a new xorg intel driver:

http://packages.debian.org/sid/xserver-xorg-video-intel

which works with this hardware. This has been in Debian Unstable for a month or more, but has still not appeared in Debian Stable (Etch).

samael26 02-17-2008 08:49 AM

Hi,
I have an unbranded laptop which came with no OS. Same chipset, though. The only distro that recognized and configured both wireless and graphics to 1200x800 was Mepis 7.0.
Cheers.

centguy 02-19-2008 09:49 PM

I did some experiments on my Fujitsu A6030. The default xorg.conf
contains a line Driver "i810", I changed it to "i915" and reboot (I have
to that a reboot if I don't want to blank screen after logout),
then I hit (Failed to Load Kernel Module "i915") problem.
After let the xserver to switch the default xorg.conf,
the file /var/log/Xorg.0.log tells me that it loads "i810"
via Loading /usr/lib64/xorg/modules/drivers/i810_drv.so.
I checked /usr/lib64/xorg/modules/drivers does not contain i915_drv.so,
so I guess this is the crux of the problem. Can it be a problem that
the 64-bit driver is not compiled properly ??
I may try a 32-bit centos5.1 to confirm my theory.

BTW, I found a related thread in this forum:
http://www.linuxquestions.org/questi...e-i915-519009/


All times are GMT -5. The time now is 02:25 AM.