-   Linux - Hardware (
-   -   Intel Audio driver issue (

Josh328 01-13-2006 11:36 AM

Intel Audio driver issue
I'm using SuSE 10 and i'm having trouble getting my audio functioning properly.

lspci shows...

00:1b.0 Class 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

Yast2 finds 2 sound cards:
HDA Intel - using the snd-hda-intel module
82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller - Not Configured

when i trie to configure it, i get the following error:
The kernel module snd-hda-intel for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

Any ideas?


MamaWombat 02-12-2006 10:17 PM

I have exactly the same problem. Intel HDA sound card with Suse 10, and no sound.
I know that ALSA are having lots of problems with this sound card. I just upgraded my kernel and ALSA to the latest stable releases and sound still doesn't work.

foolsh 02-13-2006 09:45 AM

just a thought but maybe intel sound support is not compiled it to your kernel, but i really dont know cause i've never used suse

Linux_noobnoob 02-28-2006 05:25 PM

I had the same problem. I've got the ICH5 AC97 onboard sound (its a 5.1 jobbie) and like you my rig detected two cards, one being configured as snd-cd-0, or something along those lines, and the other not being configured at all. I found that in order to configure the other one, I had to delete the first one altogether and then configure the second. This seems to have worked. Give it a go and see what happens...

All times are GMT -5. The time now is 08:28 PM.