-   Linux - Hardware (
-   -   Intel 810 integrated graphics processor (

Wakim 01-06-2005 08:07 AM

Intel 810 integrated graphics processor
I have searched through the forums about this graphics controller, and I can definately see there are problems associated with installing Fedora Core 3 with this card, and I seem to have the same. I tried my first ever install of Linux last night and couldn't get through the set-up process.

I am looking for a distribution that won't give me these problems. I want to get one version up and running so I can get aquinted with it a little before haveing to go through what I have seen others say you need to do to get it running.

If anyone knows if a specific distribution works good with this I would really appreciate it. I have downloaded FC3 and Mandrake before deciding to go with Fedora. If Mandrake would work I already have that downloaded.


masand 01-06-2005 09:25 AM

hi there

i am having intel 810 graphics adapter and i am having no problem with any distro i have tried
i haven't tried FC3 yet
FC2 is working fine for me now presently along with mandrake 10.1

this is the config of my card , got it from
kudzu -p
class: VIDEO
bus: PCI
detached: 0
driver: Card:Intel 810
desc: "Intel Corp.|82810E DC-133 CGC [Chipset Graphics Controller]"
vendorId: 8086
deviceId: 7125
subVendorId: 1043
subDeviceId: 8014
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1
pcifn: 0


2damncommon 01-06-2005 09:26 AM

Linux support for the i810 chipset is old news.
Suse has had it out of the box since 6.4
I am surprised any distro would have a problem with it now.
I ran Mandrake 7.1 and 8.0 with out of the box i810 support.
With a caveat that any distro could have a problem with some part of your hardware, I would suggest you give a Mandrake install a shot.
No doubt there will be followups to try every other distro in existance. :)

Wakim 01-06-2005 10:18 AM

Thanks. It's funny, because I have read where people didn't have the problem with FC2, but had it on upgrading to FC3. I was very surprised as well it didn't work. While the mobo is a piece of junk in general, I beleive there were enough of them sold that there would be support out of the box.

I think I will try Mandrake tonignt. I was on the fence trying to decide between that and FC3 for a while anyways.

Thanks again

Wakim 01-06-2005 08:14 PM

Well, this is my first post from Linux. I installed Mandrake 10.1 tonight and it is great!

2damncommon 01-06-2005 08:29 PM


Well, this is my first post from Linux. I installed Mandrake 10.1 tonight and it is great!
Glad Mandrake worked out for you.

DrSoCold 01-10-2005 06:03 PM

i810 and FC3
Just do a text only install ('linux text' at the install prompt) and follow my instructions from the following post, make sure you read all of the post as it is progressive.

You should have no problems with after with the i810 chipset after and all should be fine with FC3 and X.

Darin 02-20-2005 04:13 AM

I had the same problem, FC3 and integrated I810 graphics. The installer would die, or work but look so bad that I couldn't progress through the install menus.

To get around this, I did a text install, it's not as bad as it sounds. The text install is all text based menus, and doesn't require much more knowledge than the ghraphical install, it just doesn't look as pretty.

After the install, X would do the same thing, bad graphics, crashing, unreadable graphics until I found some other threads about this same problem. To get to a text console, use CTRL-ALT-F1 and manually edit the following files:

/etc/inittab optional, to get Linux to start in text mode instead of graphical mode
change this line from:

/etc/X11/xorg.conf change this section by adding the line in bold:
Section "Device"
Driver "i810"
BoardName "Intel 810"
Option "NoAccel"

The inittab does not have to be changed, but it's not a bad idea to have X not start after reboot while you are troubleshooting problems with it. Just type startx while logged into the text console when you want to test your modifications.

After getting X to run stable, I used the RedHat updater to update Xorg, along with all other updates, then I was able to remove the "NoAccel" line from my xorg.conf and haven't had problems.

All times are GMT -5. The time now is 07:17 AM.