-   Linux - Hardware (
-   -   Integrated web cam not detected on Lenovo Ideapad S10 (

etechnophile 08-11-2012 09:22 AM

Integrated web cam not detected on Lenovo Ideapad S10
I've just gotten my hands on an old Lenovo Ideapad S10. Installed OpenSUSE 12.1 on it. It works fine, except that the integrated webcam has not been detected by both Skype and Cheese. I tried connecting an external USB webcam (Logitech C110) and that works fine in both Skype and Cheese. I'm not sure what to do next. How I can get the integrated webcam working?


linux-grt2:~ # lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
05:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
linux-grt2:~ # lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 002 Device 002: ID 062a:0000 Creative Labs Optical mouse
Bus 003 Device 002: ID 0a5c:2150 Broadcom Corp. BCM2046 Bluetooth Device

aus9 08-11-2012 08:56 PM


your lsusb is not good

can you check your bios and see if webcam is disabled pls

abrinister 08-12-2012 08:35 PM

Can you post the output of


arecord -l
Alex Brinister

etechnophile 08-22-2012 08:10 AM

Sorry for the late reply. Thanks a lot for taking time to help me!

@aus9: I checked my BIOS, but did not find anything about webcam enabled/disabled. Am I missing something?

@abrinister: Here's the output.


username@linux-grt2:~> arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aus9 08-22-2012 08:17 AM

google suggests you are supposed to see lsusb data of 5986:0241 Bison


hmm some old links found but its supposed to be a uvc compliant webcam

chicken and egg problem, hardware is supposed to be detected but does your kernel have uvcvideo module?



sudo su
modprobe uvcvideo

aus9 08-22-2012 08:35 AM

ok you might get the module to load but your cam may need a quirk....according to google



modinfo uvcvideo
and post the results

i show my last bit of results for a diff uvc cam

parm: clock:Video buffers timestamp clock
parm: nodrop:Don't drop incomplete frames (uint)
parm: quirks:Forced device quirks (uint)
parm: trace:Trace level bitmask (uint)
parm: timeout:Streaming control requests timeout (uint)

etechnophile 08-22-2012 09:51 AM

@aus9: Here's the output you requested. BTW, I'm not sure about this - but I think Logitech C110 is a UVC webcam, and that worked fine when I plugged it in. So I think UVC module in the kernel may not be the problem. Perhaps something is wrong with the internal webcam's hardware? If that's the case, how can I check for it?


linux-grt2:~ # modinfo uvcvideo
filename:      /lib/modules/3.1.10-1.16-default/kernel/drivers/media/video/uvc/uvcvideo.ko
version:        1.1.1
license:        GPL
description:    USB Video Class driver
author:        Laurent Pinchart <>
srcversion:    5435E40B226AA7B55C93F0C
alias:          usb:v*p*d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v1C4Fp3000d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v1B3Bp2951d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v19ABp1000d00*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v19ABp1000d01[0-1]*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v19ABp1000d012[0-6]dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v18ECp3290d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v18ECp3288d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v18ECp3188d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v18CDpCAFEd*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v1871p0306d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v17EFp480Bd*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v17DCp0202d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v174Fp8A34d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v174Fp8A33d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v174Fp8A31d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v174Fp8A12d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v174Fp5931d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v174Fp5212d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v152Dp0310d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v13D3p5103d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v0E8Dp0004d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v0AC8p3420d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v0AC8p3410d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v0AC8p332Dd*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v06F8p300Cd*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v05E3p0505d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v05C8p0403d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v05ACp8501d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v058Fp3820d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v04F2pB071d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v046Dp08C7d*dc*dsc*dp*icFFisc01ip00*
alias:          usb:v046Dp08C6d*dc*dsc*dp*icFFisc01ip00*
alias:          usb:v046Dp08C5d*dc*dsc*dp*icFFisc01ip00*
alias:          usb:v046Dp08C3d*dc*dsc*dp*icFFisc01ip00*
alias:          usb:v046Dp08C2d*dc*dsc*dp*icFFisc01ip00*
alias:          usb:v046Dp08C1d*dc*dsc*dp*icFFisc01ip00*
alias:          usb:v045Ep0723d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v045Ep00F8d*dc*dsc*dp*ic0Eisc01ip00*
alias:          usb:v0458p706Ed*dc*dsc*dp*ic0Eisc01ip00*
depends:        videodev,usbcore
vermagic:      3.1.10-1.16-default SMP mod_unload modversions 586TSC
parm:          clock:Video buffers timestamp clock
parm:          nodrop:Don't drop incomplete frames (uint)
parm:          quirks:Forced device quirks (uint)
parm:          trace:Trace level bitmask (uint)
parm:          timeout:Streaming control requests timeout (uint)
linux-grt2:~ # modprobe uvcvideo
linux-grt2:~ #

abrinister 08-22-2012 12:58 PM


Originally Posted by abrinister (Post 4752759)
Can you post the output of


arecord -l
Alex Brinister

Wow I'm an idiot. I confused internal webcam with internal microphone.

Post the output of the following:


dmesg | grep uvc
Alex Brinister

aus9 08-22-2012 06:54 PM

and I want you to re-visit bios

have a read of this link pls

yes its not your laptop but try this

F1 → Security → I/O Port Access → Integrated Camera

I am suggesting that webcam can be turned off in bios which is why we don't see lsusb output

etechnophile 08-22-2012 11:31 PM

@aus9: I tried pressing F1 repeatedly, but nothing happened. F2 gets me into BIOS. I found a tab called Security, but it only lets me set the supervisor password which controls access to the BIOS. I looked around in other tabs too, but found nothing about a webcam. I don't have windows installed, so can't check that.

@abrinister: My internal microphone works in Skype :-) Here's the output you asked for.


linux-grt2:~ # dmesg | grep uvc
linux-grt2:~ #

aus9 08-23-2012 01:09 AM

ok I shall flog a dead horse

f2 gets you into bios good to know

I don't have a webcam but maybe....its a long shot....forgive me....its under a different setting

I look at my bios manual and me thinks its under

Integrated perispherals....but I don't have a hoo

on my bios ....this is where I can turn off my onboard sound..LAN and so on

pls report if you see may be a sub-menu under usb or video

good luck

aus9 08-23-2012 01:20 AM

google suggests

press Function key + Escape keys together.....may enable webcam???

abrinister 08-23-2012 03:10 PM

It does seem like it's either a hardware problem (probably a wiring problem if you have taken the thing apart in the past) or a BIOS problem. Either that or it's some really funky webcam you have. Most are compatible with linux via V4L (Video for Linux) and UVC.

Alex Brinister

etechnophile 08-23-2012 11:10 PM

3 Attachment(s)
@aus9: Tried Function key + Escape combination with skype/cheese running, but no change observed.

Have also attached the photos of all tabs of the BIOS except the last one, since only 3 photos are allowed per post. I'll attach the last photo in another post.

@abrinister: Yes, it does look like it might be a hardware problem. And the laptop is not covered under warranty anymore :-( Thanks for your help!

etechnophile 08-23-2012 11:11 PM

1 Attachment(s)
@aus9: Here's the photo of the last tab in my BIOS.

All times are GMT -5. The time now is 02:35 PM.