-   Linux - Hardware (
-   -   Installing Slack 12.2 on a Promise 20276 (

technik733 05-25-2009 12:25 AM

Installing Slack 12.2 on a Promise 20276
I am trying to install slackware onto the second partition of my striped RAID array that is being run by a Promise 20276 chip, and I have almost no idea how I would go about doing that.

I've tried loading ataraid.i as the kernel, but seemingly slackware does not possess this. I've also tried to find a linux version of the driver and load it manually before setup, but I have not been able to find the driver for linux. I've read online about someone having the sourcecode so they built it, which I could do since I have another slack machine, but after they rebooted after the installation there was a kernel panic saying that it couldn't access the root filesystem.

So now I'm here. Please help! :(

technik733 05-25-2009 02:04 AM

1 Attachment(s)
Ok, I've done some quick reading online about raid in linux... but I'm still not a lot closer to getting it figured out. I do however have a complete dmesg output, if it's any help.

From looking at it myself it looks like it's trying to load the individual disks... it's odd because it can read the 320GB western digital in cfdisk, even though it's striped, but it can't read either of the 120GB Maxtors because it either says that the partition ends after the end of the drive(hde, I think), or it says that it's in some way invalid (hdg, I think). Forgive me for not retaining all of the details, I'm posting from the same pc in windows.

Erm... I would post it with code tags but the Unix end of line thing makes it atrocious looking in notepad. 'Tis attached.

technik733 05-25-2009 02:36 AM

*sigh* Apparently it's fake raid. -_- Now the problem is that I have to get it working without breaking the windows installation. I am NOT going to start over and go without raid, however fake it may be. It took over a day to get everything working in XP... Is there any way to do it without building an ataraid.i kernel for slackware and sticking that on the disk then burning it again and installing from there? 'Cause while I think I know what I'd have to do I'm not sure, and don't know how to build it for ataraid.i, especially when I don't have a functioning version of linux on here. I did find this site though:

AwesomeMachine 05-25-2009 03:19 AM

Here's what I found:

[sam@f10 ~]$ sudo /sbin/modinfo pata_pdc202xx_old
filename: /lib/modules/
version: 0.4.3
license: GPL
description: low-level driver for Promise 2024x and 20262-20267
author: Alan Cox
srcversion: A3B41FF8D8CEAFAD2E8A777
alias: pci:v0000105Ad00004D30sv*sd*bc*sc*i*
alias: pci:v0000105Ad00000D30sv*sd*bc*sc*i*
alias: pci:v0000105Ad00000D38sv*sd*bc*sc*i*
alias: pci:v0000105Ad00004D38sv*sd*bc*sc*i*
alias: pci:v0000105Ad00004D33sv*sd*bc*sc*i*

So it looks like the module you want to load is: 'pata_pdc202xx_old'. You should be able to use a grub kernel parameter: 'install pata_pdc202xx_old', or wait until it boots, and grab a free terminal, and 'modprobe pata_pdc202xx_old', or you can email Alan Cox, and ask him how to handle this module.

If you load it on installation, the system should install it automatically after that.

technik733 05-25-2009 03:22 AM

Hmm... it's a bit newer than what that says it supports, but it's certainly worth a try. Thanks a ton, I'll see what I can do with that.

EDIT: Erm... I can't seem to modprobe it after it's booted the cd with the default settings, so it make me wonder if the slackware disk actually has it. If that were the case, where would I find it?

About a grub kernel parameter, I'm not sure that slackware uses grub... But then again I'm a relative newb so I'll go try it as soon as I have it written down. Had to come back to see it since I can't read text files until after I boot. >.>

AwesomeMachine 05-25-2009 03:35 AM

There is also a module called pata_pdc2027x. You might also try that one.

technik733 05-25-2009 12:39 PM

Aah, yeah that might work better. I'm having a problem loading it though... I don't think slackware has it; it says the file is not found when I try to use modprobe, and I'm not sure if I'm trying to load it in the boot parameters correctly. I used "hugesmp.s install pata_pdc202xx_old" and nothing happened. I'll try it with the file extension as well... but I'm not even sure if that's correct.

If the module isn't on the slackware DVD, where could I obtain it?

EDIT: Also according to the Promise_IDE module specifically supports my chip, the "Promise Technology / MBFastTrak133 Lite (tm) Controller." It's shown as the only module that supports it as well. So how do I use the darn modules?!

There's also this.

EDIT x2: Ok, I found pata_pdc2027x in the kernel modules tar file on the dvd, so where do I go from there? And what about "Promise_IDE"?

I've gone so far as to extract the modules in windows and put them on a floppy so I can load them without extracting into the ramdrive. But I still don't know how to run cfdisk, or even confirm if ther are working.

technik733 05-25-2009 04:07 PM

I've still had no luck... what's the device name for the pata_pdc2027x driver?

According to dmesg, it seems to have loaded pdc202xx_new, which seems to be an IDE driver rather than a raid bus driver. =( How does this affect things?

Edit: It seems that this IS Promise_IDE that was referring to... so how to I set it up?

All times are GMT -5. The time now is 10:12 AM.