LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Installing RHEL 4: no device driver for SATA HDD (https://www.linuxquestions.org/questions/linux-hardware-18/installing-rhel-4-no-device-driver-for-sata-hdd-592448/)

cool_guy_km 10-17-2007 04:40 AM

Installing RHEL 4: no device driver for SATA HDD
 
Hi,

I am trying to install RHEL 4. During the installation ,it can't detect my hard disk and ask for device drivers. I am using SATA HDD. But any case, the installation did n't complete and exit with error message, "No Hard Drive found".


My System Details:
Mother Board: Intelchipset(mercury)Board 945

HDD : Hitachi SATA
Linux : Red Hat 4
kernel:2.6

From where i get device driver for SATA HDD

Thanks in advance

Regards,
Noushad K M

strick1226 10-17-2007 03:24 PM

It might help to change the SATA mode in the motherboard's BIOS to "compatible" or something along those lines... (I sincerely doubt you will notice much, if any, performance loss.

Failing that...


I think I ran into this a while back. Digging through some notes I think that update3 was one of the first to include a kernel that worked with most of the common SATA controller vendors...

Here's a link: https://rhn.redhat.com/errata/RHSA-2006-0132.html

Probably the easiest thing to do would be to download the most up-to-date RHEL4 installation ISO's and perform your install using them instead. For that you will need a valid support contract...

If you want the stability of RHEL without the official support (and accompanying price) I recommend considering CentOS. It's the community-supported release of RHEL, 99% identical in every way, built from the same Redhat-supplied source.

Check out CentOS at http://www.centos.org


All times are GMT -5. The time now is 06:50 AM.