-   Linux - Hardware (
-   -   Installing Redhat 8 with a Compaq USB Internet Key Keyboard (

Sam S 03-30-2003 05:59 AM

Installing Redhat 8 with a Compaq USB Internet Key Keyboard
I am attempting to install Linux Redhat 8.0 on my Compaq Presario 5032UK machine. Simple problem is that it came with a USB keyboard, the type with Internet buttons all over it, and it won't see it for the install process.

I have been everywhere looking for help on this matter, but noone seems to have a real solution to it. The keys work fine when the screen comes up asking if I want text or graphical install, but then stop working.

One popular suggestion seems to be disabling legacy USB keyboard support in the Bios, but this just makes it not possible to choose between text and graphical, and when this screen times out and moves on to the install one, keyboard is still dead.

The screen I am getting up to is the "Shall I test the media you are using" one. It's not even graphical, still text based, so that rules out the other suggestions of it being the GUI thats not finding it.

The other suggestion seems to be to get a PS/2 Keyboard, but quite frankly I can't see the point in that waste. Now, I can get hold of one to go through the install process, but I want to have this one on afterwards, so is there a way of installing this one after the system is installed?

1) How do I get the install program to see my computer (ideal solution!)
2) How do I / Can I install my Keyboard for use after an install has been completed?
or even
3) Will any other versions of linus not run into this problem, and are they any good in comparison to Redhat (although this really is a totally seperate issue...!)

Drawn out I know, but hope someone out there has some answers for me on this one! Cheers!

sastradhar 05-28-2003 06:40 AM

I have a compaq presario with a USB key board some how my key board is not being recognised when I tried to install RH7.2 or RH8. Can some one tell me how to circumvent this problem. TIA

Amitesh 06-07-2003 04:24 AM

I had the same problem . I have solved it by upgreading bios .
If the bios supports usb devices then it's ok. Otherwise upgrade

All times are GMT -5. The time now is 01:25 PM.