-   Linux - Hardware (
-   -   Installing nVidia drivers in SuSE 9.1 fails with GeForce 3 (

Mattus 11-06-2004 09:04 AM

Installing nVidia drivers in SuSE 9.1 fails with GeForce 3
I am trying to get the 3d acceleration on my GeForce 3 card to work in SuSE 9.1.
I have tried installing the nVidia drivers through the YaST online update, but I just get a corrupted display. Can anyone help? Keep it simple please as I am quite new to Linux.

I thought one possibility might be a problem with my monitor - a Relisys TE770-RU. This is not in the driver list, but I tried setting it up as a TE772. The monitor still works fine in 2D mode, but installing the nVidia drivers still failed.


Some Info:
> /sbin/lspci
0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 10)
0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
0000:00:02.0 ISA bridge: Silicon Integrated Systems [SiS]: Unknown device 0963 (rev 25)
0000:00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0016
0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
0000:00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
0000:00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 91)
0000:00:0c.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
0000:00:0c.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3] (rev a3)
> uname -r

Mattus 11-07-2004 06:41 PM

Managed to solve my own problem here -
I tried bypassing YaST completely and downloading the patch directly from the nVidia website (although the website advises you not to do this).
It took a little time to get going as the installer recompiles the the kernel, so I needed to first download the kernel source (and a compiler), but it did work!

johnford 11-08-2004 09:36 AM

possible there is a conflict with the rivafb module, i had to compile a kernel that did not have rivafb support. I would use the .run from the nvidia site, as i cant for the life of me figure out how to get the drivers from YOU to work, and there are new nv drivers

Mattus 11-08-2004 10:10 AM

I did get a warning about a conflict with the rivafb module when I ran the nvidia installer, but I ignored it and carried on anyway. Everything seems to work fine now. I don't actually have a clue what rivafb is, so I am just crossing my fingers here and hoping it will not cause a problem.

johnford 11-08-2004 11:41 AM

rivafb is the driver for TNT RIVA cards i think, did you use the sax2 -m 0=nvidia with the YOU update proscess as well?

Mattus 11-08-2004 06:06 PM

I think when I tried to install using YOU it ran sax2 automatically. It then gave me the black screen. When I installed without YOU, I changed "nv" to "nvidia" in the xfree86 config file, then just ran sax2 (with no arguments) to turn the 3d option on. If rivafb is for TNT cards only, my geforce should be no problem?

Mattus 11-08-2004 06:10 PM

Correction to my last post - I did not in the end need to change nv to nvidia. Sax2 did that itself.

johnford 11-09-2004 09:27 PM

it conflicts with the driver!

All times are GMT -5. The time now is 06:41 PM.