LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Installing Kyro II on Suse 9 (https://www.linuxquestions.org/questions/linux-hardware-18/installing-kyro-ii-on-suse-9-a-127793/)

boffhaku 12-21-2003 08:57 AM

Installing Kyro II on Suse 9
 
Hi all,
I'm having a bit of bother with installing the Kyro II drivers on Suse 9.
I downloaded the source tgz and the src.rpm and tried the install with both. Both failed when trying to install the driver module. I get this error: -

depmod: *** Unresolved symbols in /lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol remove_proc_entry_R5c65f2d8
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol add_wait_queue_Raf1b06bf
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol register_chrdev_Rb742e083
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol remove_wait_queue_Ra0616a3b
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol fasync_helper_R452259c8
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol vmalloc_to_page_Rabcea0d0
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol mem_map_R4869e273
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol kill_fasync_Redc564d7
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: unresolved symbol create_proc_entry_R8dd8692b
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: insmod /lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o failed
/lib/modules/2.4.21-144-default/kernel/drivers/char/drm/powervr.o: insmod powervr failed
To continue installation read /usr/share/doc/powervr-2.00.20/README

To get this far I installed the kernal sources and ran
make cloneconfig && make dep
in the kernal source directory.
Like I said, I've tried with the PowerVR source download, and I get a similar error message when running make install.
The above message I get when i try to install the rpm built from the powervr src.rpm download.
Anyone have a Kyro running on Suse9 and can Help? Or shall I just pester PowerVR to create Suse 9 rpms for the Kyro!
Thanks


All times are GMT -5. The time now is 10:40 PM.