-   Linux - Hardware (
-   -   Installing Kubuntu on SATA drive fails, KV8-MAX3, Maxtor HD, On-board raid controller (

darkon06 04-20-2006 03:49 PM

Installing Kubuntu on SATA drive fails, KV8-MAX3, Maxtor HD, On-board raid controller
First the specs:

KV8-MAX3 Mobo
(I'm using the on-board NIC, Sound, and RAID controller)
two Maxtor drives:
ATA 20(or 30 i can't remember) Gigs
SATA 250g (I think) - hooked up to sata1
two video cards
PCI GeForce II
AGP GeForce.... (i can't remember this one, if you need it please ask)

I can't think of anything else you might need but if you do i'll be more than happy to go look.


I have had linux on this system before but a couple months ago my second ide drive burnt to a crisp and was giving me random errors and such. So i pulled it out and just used Windows XP on the other drive and bid my time untill i got the money and time to buy a new drive for linux. Well I got the money and decided to buy a SATA drive for kicks mostly and the price was right so I got it off newegg a week or so ago.. well okay probly longer than that but i'm still short on time.

So i hooked it up, but it on sata port one on the mobo and intstalled kubuntu on the SATA drive, leaving the IDE the way it was. It installed fine, booted back up and was installing the software i think and around 74% it kept going but my machine sounded the system alarm. (later on i tried this again and let it go with the alarm going off and it soon after dropped into a console and was spitting out kernel panic msg's saying somethign wasnn't syncing) but... Thinking it was overheating or somethign serious was goign on i quickly flipped the power switch on the back of my PSU. I let it sit for a min and turned it back on. No alarm, I pulled up the temps in the bios and everything was cool and running fine.

So i reboot and let the machine boot up with the HD knowing it would be corrupted or at the least incomplete, it started fine and even gave me a login screen (console though, no X was started) but then soon after the alarm sounded and i left it on again and logged in on my account. and tried to snoop around in the log files. To be honest i'm not the most brilliant linux guru and couldn't make any sense of them. So with the alarm driving my crazy i turned it off and tried installing linux (same distro) on the IDE drive, same thing happens though. Keep in mind that this box worked fine with several distros before i installed the sata drive.

Then i tried installing different distro's thinking my copy was bad, I tried an old version of Ubuntu that i knew was good, I tried version 5.4 (i think) of Kubuntu which i havn't tried before (my first try was Kubuntu 5.10 i think? All of these gave me exactly the same problems.

So i checked my memory with memtest, checked my connections and looked over my bios but nothing looks amis. I'm stumped and kinda pissed. Sorry for the long dialouge btw, but any help would be much appreciated.

Thanks in advance,

Electro 04-22-2006 03:13 AM

Use only the VIA SATA controller. Turn off the Silicon Image SATA controller in the BIOS. Silicon Image SATA controller are known to give problems especially with Maxtor SATA hard drives. I suggest Hitachi or Western Digital SATA hard drives. Maxtor and Seagate SATA hard drives are the worst because they produce errors while in operation.

When the computer produced the alarm, probably the processor was overheating. The time you waited and how cool the ambient temperature is made the processor cool down just enough, so you can not find out if the processor is overheating. On my Abit motherobard (TH7II-RAID), I just turn off temperature alarm, but I left on fan alarm.

Remove the PCI card because GeForce2 in the old days have problems with power supplies on motherboards.

darkon06 04-22-2006 12:00 PM

First, thanks for the help. But now...


Use only the VIA SATA controller. Turn off the Silicon Image SATA controller in the BIOS.
I can only find SATA mentioned in the bios in "OnChip IDE Device" and its labeled "SATA RAID ROM" Theres some other controllers dealing with hard drives, but none SATA specific other than that. (I think :-\ ) Theres also a VIA Tech SATA RAID BIOS Ver. 4.31 that I can get into, but nothing marked as a "Silicon Image" controller.


Electro 04-22-2006 04:06 PM

Read the motherboard manual. It will tell you want option is the Silicon Image controller.

darkon06 05-01-2006 08:51 AM

I've read the mobo manual, there is no way (it seems) to turn either SATA controller off. So I tried changing which controller it was on, well I can only use the VIA controller because the Silicon Promise? (is that right?) controllers outputs arn't there and the controller itself seems to be missing from the board... is this right? I have a KV8-MAX3. But still I changed the drive from port one to two and that didn't work.

I'm wondering if the HD is overheating or something because the alarm keeps sounding, it seems to me that the heat must be the real culprit for this set-up not functioning but I can't see whats making the alarm sound. So i played around with the BIOS alarm settings and turned off the CPU alarm and FAN FAILURE alarm. After this I rebooted where the alarm still sounded... I'm just not sure what else could be the problem.

About the GeForce II board, what problems exactly do these boards cause? I tried finding some material and answers from google but couldn't really find much.

Thanks for the help Electro.

darkon06 05-01-2006 09:31 PM

Hmm, well it seems like my HD is fine perhaps? I removed the drive from my machine and tried installing the distro on the IDE drive, well this fails as per my symptoms that i described earlier. Poking around my machine i found the stupid NB fan is dead. Perhaps i'll replace it with just a heat sink and see if that solves my mystery heat issue? (I'm assuming its a heat issue, I really don't have a clue whats going on)

When i have results I'll let you all know, (not that you care ;-) )

All times are GMT -5. The time now is 04:29 AM.