LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-25-2004, 12:59 PM   #1
Darrell22
Member
 
Registered: Nov 2003
Posts: 83

Rep: Reputation: 15
Angry Installing ATI Radeon video drivers on Redhat Advanced Server


Dear Experts,

Sorry, I'm back. Now, I'm struggling with the video
drivers on Redhat once again. I've spent about 6 hours
so far. Hopefully someone will know the secret.


I'm running:
Redhat Advanced Server 2.1
ATI Radeon 9000 All-In-Wonder in the AGP slot
Xfree86 4.1.0

I downloaded the driver from ATI.
fglrx-glc22-4.1.0-3.7.0.i386.rpm

I installed the package. Then, I tried running
fglrxconfig, and
Xconfigurator

But both of them failed.

-----------

The tail output from /var/log/XFree86.0.log is:

(II) Primary Device is: PCI 01:00:0
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:0) found
(EE) No devices detected.

Fatal server error:
no screens found

-----------

/lib/modules/fglrx/make_install.sh
- creating symlink
- recreating module dependency list
depmod: *** Unresolved symbols in /lib/modules/2.4.9-e.3/kernel/drivers/char/drm/fglrx.o
failed.

strings /usr/X11R6/lib/libGL.so.1 | grep dlsym
dlsym

-----------


lspci shows:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4966 (rev 01)
01:00.1 Display controller: ATI Technologies Inc: Unknown device 496e (rev 01)


------------

try to run: startx
and get much the same output as before:


(II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP),
ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP),
ATI Radeon VE QY (AGP), ATI Radeon VE QZ (AGP),
ATI Radeon Mobility LW (AGP), ATI Radeon Mobility LY (AGP),
ATI Radeon Mobility LZ (AGP)
(--) Assigning device section with no busID to primary device
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found
(EE) No devices detected.

Fatal server error:
no screens found


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.


---------------

The interesting thing is the config file: XF86Config-4
(below) The Video card is unknown!


---------------

When I installed with Suse, it automatically chose these
settings automatically, and it worked perfectly fine. I don't
need any 3D. I just need it work with regular graphics.


ATI RV250 lf(radeon)
connected to monitor NEC XV15+ (1280 x 1024 @ 16bit)
3D acceleration disabled.

Where could I get this driver?


--------------


Does anyone have a working ATI config file that
they could post?


Thanks a lot!



--------------
Config file: XF86Config-4

# XFree86 4.0 configuration generated by Xconfigurator

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# By default, Red Hat Linux 6.0 and later use xfs

Section "Files"
FontPath "unix/:7100"
EndSection

# Module loading section

Section "Module"
Load "dbe" # Double-buffering
Load "GLcore" # OpenGL support
Load "dri" # Direct rendering infrastructure
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "pex5" # PHIGS for X 3D environment (obsolete)
# Load "record" # X event recorder
# Load "xie" # X Image Extension (obsolete)
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "off"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "NEC MultiSync XV15+"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 31.0-65.0
VertRefresh 55.0-100.0
Option "dpms"
EndSection

Section "Device"
Identifier "My Video Card"
Driver "radeon"
BoardName "Unknown"
Option "nodri"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "My Video Card"
Monitor "NEC MultiSync XV15+"
DefaultDepth 16
Subsection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
Subsection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble installing ATI Radeon 9600 Drivers in Mandrake RAMMS+EIN Linux - Hardware 2 05-27-2005 03:58 PM
Problems after installing ATI radeon drivers in Mandrake 10 Cetrocet Mandriva 8 05-21-2004 04:32 PM
DVI doesn't work on Radeon 9200 on LCD on Redhat 8, ATI drivers edwardt Linux - Hardware 0 05-13-2004 06:32 PM
Has anyone able to install ATI Radeon 9600XT drivers on RedHat 9? DriveMeCrazy Red Hat 3 03-25-2004 10:55 AM
Installing Video card (ATI radeon 9200) crashdum Linux - Hardware 1 09-07-2003 04:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration