-   Linux - Hardware (
-   -   installing a Dell 1320cn laser printer with ubuntu 9.10 (

itbod 02-04-2010 01:49 PM

installing a Dell 1320cn laser printer with ubuntu 9.10

Just purchased new del 1320cn printer and unfortunatly ubuntu doesn't see it. I tried the Foomatic system as well, which does see the printer and identifies it but does not show the model number in the list.

Any help would be really good. My other Del 1110 mono laser worked first time!

If any terminal commands reqd, please could you be kind enough to list them as I get confused using terminal .

Kind regards


distro: ubuntu 9.10
Printer: Del 1320cn Colour Laser Printer

ongte 02-05-2010 08:48 AM

This printer is an OEM version of the Fuji Xerox DocuPrint C525A printer.

You will find the driver here:

You convert the rpm to deb using alien.

itbod 02-05-2010 09:23 AM

Fantastic! Thanks for that, I will do it now.


itbod 02-05-2010 11:32 AM

Oh dear, here we go again! Where do I extract the files to and how do I install the driver? I am not very good at terminal so need to be nurse maid through it, sorry, I have trouble using terminal commands instead of MSDOS commands(sorry I swore there)


ongte 02-05-2010 10:07 PM

Ok, here's rough step-by-step:

$ unzip
$ cd C525A_LinuxE
$ sudo apt-get install alien
$ alien Fuji_Xerox-DocuPrint_C525_A_AP-1.0-1.i386.rpm
$ sudo dpkg -i Fuji_Xerox-DocuPrint_C525_A_AP-1.0-1.i386.deb
Now try to configure your printer by choosing this model.

itbod 02-07-2010 11:03 AM

Thank you for this info, I will try it out on monday.


itbod 02-19-2010 10:49 AM

Sorry to bother you again, I have not been able to get my Dell printer to work yet, tried the above and ubuntu says it can't find alien. There must be an easier way of doing this. Any ideas??

Regards in despair


tairoesp 02-24-2010 12:14 PM

If Ubuntu can't find alien, probably it isn't on its apt-get repository. If I were you, I would try to get it from a debian package from the net, like the one above:

Just choose the newest alien.deb version, install it and do the steps like explained by ongte, skipping the apt-get install one.

Hope it helps you!

itbod 02-25-2010 07:02 AM

thanks tairoesp, I will try this later and let you know

itbod 03-04-2010 11:57 AM

Hi tairoesp

Just to let you know, it now works thanks to all you guys on here. One thing though, but I can live with it for the moment, the printer will not pick paper up from the tray, it asks only for single sheets to be placed in the sigle sheet feeder on the front. i know it's not the printer as it works perfectly on the network with other windows based machines. but at least i can get it to print from my ubuntu system.

Thank you all once again


All times are GMT -5. The time now is 12:38 PM.