LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-03-2004, 04:20 PM   #1
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Rep: Reputation: 0
installation problem with 536ep modem


Hi!
i'd like to install my 536ep internal modem ( Intel chipset ) on my slackware 10.0 with kernel 2.4.6.
I tried to install some drivers from downloadfinder.intel.com, but without any good results.
I followed all the instructions written in readme.txt file. But it gives me an error when i run make install.

# make clean -> work good
# make 536 -> work good, without errors
# make install ->
rm -f /etc/hamregistry.bin
bash Intel536_inst
running Kernel 2.4.6
installing hamregistry, used for persistant sorage
installing Intel536 driver
unknow distribution. no boot installed
make: *** [install] Error 1


how can I solve my problem ? i really like to install 536ep modem on my slackware 10, it's very important for me, can u help me please ?
 
Old 09-03-2004, 04:27 PM   #2
bobwall
Member
 
Registered: Jul 2004
Location: Milpitas, California
Distribution: 1/2 Debian 1/2 my own
Posts: 189

Rep: Reputation: 30
Maybe the driver installation script is old and it doesn't recognize slackware 10. You can always manually install the drivers since you've got them compiled. Just put those drivers somewhere in /lib/modules/2.4.6 (the module files should end in extension ko). Then cd into /lib/modules/2.4.6 or whereever you put them and execute "insmod *" where * is the main module file for your modem.

To make this be done automatically during boot up, find out what configuration file slackware uses to load modules at boot up time.
 
Old 09-03-2004, 04:36 PM   #3
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
tnx for ur answer :-)

but i'm italian and i'm a beginner, i never done what u wrote, so can u tell me what i have to do in a more simple way please ? :-)
 
Old 09-03-2004, 04:41 PM   #4
bobwall
Member
 
Registered: Jul 2004
Location: Milpitas, California
Distribution: 1/2 Debian 1/2 my own
Posts: 189

Rep: Reputation: 30
As root, start a console and go into the directory where you build the modules

first test to see if the modules will load:
"insmod *.ko"
 
Old 09-03-2004, 05:40 PM   #5
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ok i will try it, and then i'll tell u if the modelus will load correctly...
 
Old 09-04-2004, 08:35 AM   #6
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
only a question... what i have to do to know where is the right directory ?
 
Old 09-04-2004, 09:33 AM   #7
bobwall
Member
 
Registered: Jul 2004
Location: Milpitas, California
Distribution: 1/2 Debian 1/2 my own
Posts: 189

Rep: Reputation: 30
Just go to the same directory where you did the "make" and try this time to load the modules that you have built ("insmod *.ko")
 
Old 09-04-2004, 05:47 PM   #8
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
when i run " insmod *.ko " it give me an error.
When i boot linux and before to start kde session, it gives me an error: " can't load 536ep module " ...

i think something should be changed in drivers' files in order to adapt the files to the slackware 10...

p.s. i just installed kernel 2.6.7... it works well, but there is the same problem...
 
Old 09-04-2004, 05:52 PM   #9
bobwall
Member
 
Registered: Jul 2004
Location: Milpitas, California
Distribution: 1/2 Debian 1/2 my own
Posts: 189

Rep: Reputation: 30
what is the error message when you try to insert the modules? (i.e. invalid version, etc). Also do a
"modinfo *.ko" and post it along with your gcc version (find out with "gcc --version") and kernel version (find out with "uname -a")
 
Old 09-04-2004, 06:01 PM   #10
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
i try to find this information and then i'll tell u the results...

before doing this i'd like to post this too:

Code:
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# make clean
cd coredrv; make clean
make[1]: Entering directory `/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv'
rm -f *.ko *.o *~ core
make[1]: Leaving directory `/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv'
rm -f *.o *.ko
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# make 536
   Module precompile check
   Current running kernel is: 2.6.7
   /lib/modules...   autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: No such file or directory
   autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: No such file or directory
   version.h matches running kernel
uname -r|grep "2.6" && \
cd coredrv && make 536core_26 && \
cp Intel536.ko .. && cd .. && \
strip --strip-debug Intel536.ko && \
exit; \
ls Intel536.ko >/dev/null 2>&1 ||  uname -r | grep "2.6" && echo "Failed to build driver" && exit; \
if [  ]; then \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_SOURCE_PATH= "PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
else \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_INCLUDES=/lib/modules/`uname -r`/build/include \
       "PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
        fi ; \
cp Intel536.o .. ; \
if [ -a /boot/vmlinuz.version.h ]; then \
        cp /boot/vmlinuz.version.h /lib/modules/`uname -r`/build/include/linux/version.h;\
        fi
2.6.7
make[1]: Entering directory `/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv'
make -C /lib/modules/2.6.7/build SUBDIRS=/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv modules
make[2]: Entering directory `/usr/src/linux-2.6.7'
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.o
/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.c:756: warning: initialization from incompatible pointer type
/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.c:757: warning: initialization from incompatible pointer type
/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.c: In function `dspdrv_CommRamISR':
/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.c:879: warning: function declaration isn't a prototype
/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.c: At top level:
/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/coredrv.c:286: warning: `power_callback' defined but not used
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/clmmain.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/rts.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/task.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/uart.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/wwh_dflt.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/locks.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/softserial_io.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/softserial_ioctl.o
  CC [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/softserial.o
  LD [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/Intel536.o
  Building modules, stage 2.
  MODPOST
  CC      /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/Intel536.mod.o
  LD [M]  /root/Desktop/drv/intel-536EP-2.56.76.0/coredrv/Intel536.ko
make[2]: Leaving directory `/usr/src/linux-2.6.7'
make[1]: Leaving directory `/root/Desktop/drv/intel-536EP-2.56.76.0/coredrv'
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# make install
rm -f /etc/hamregistry.bin
bash Intel536_inst
running kernel 2.6.7
installing hamregistry, used for persistant storage
installing Intel536 driver
unknown distribution. no boot scripts installed
make: *** [install] Error 1
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmod *.ko
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmode *.ko
-bash: insmode: command not found
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmod *.ko
insmod: error inserting 'Intel536.ko': -1 File exists
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# updatedb
warning: updatedb: could not open database: /var/lib/slocate/slocate.db: No such file or directory
 
Old 09-04-2004, 06:15 PM   #11
bobwall
Member
 
Registered: Jul 2004
Location: Milpitas, California
Distribution: 1/2 Debian 1/2 my own
Posts: 189

Rep: Reputation: 30
I think that your modem module loaded successfully. Now you just need to find the modem device node:

"cd /dev"
"ls 536ep"

if the file is found then
"ln -s 536ep modem" and you are done and can go ahead and start using the modem

if not, then report back


Tell me how this goes. If it works, then all you need to do is to put the modem module into
/lib/modules/x.x.x (where x.x.x is your kernel version) and configure your system to load it automatically.
 
Old 09-05-2004, 04:47 AM   #12
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
i think this is important for u :

Code:
root@darkstar:/dev# ls 536ep
/usr/bin/ls: 536ep: No such file or directory
root@darkstar:/dev# ls modem
/usr/bin/ls: modem: No such file or directory
root@darkstar:/dev# ln -s 536ep modem
root@darkstar:/dev# ls
adsp@     fd0u1722  misc/      ram8@    tty22@  tty48@   ttyS15@  ttyS40@  vcsa1@
adsp1@    fd0u1743  mixer@     ram9@    tty23@  tty49@   ttyS16@  ttyS41@  vcsa2@
agpgart@  fd0u1760  mixer1@    random   tty24@  tty5@    ttyS17@  ttyS42@  vcsa3@
audio@    fd0u1840  modem@     rd/      tty25@  tty50@   ttyS18@  ttyS43@  vcsa4@
audio1@   fd0u1920  mouse@     rtc@     tty26@  tty51@   ttyS19@  ttyS44@  vcsa5@
cdrom@    fd0u2880  null       shm/     tty27@  tty52@   ttyS2@   ttyS45@  vcsa6@
console   fd0u3200  nvidia0    snd/     tty28@  tty53@   ttyS20@  ttyS46@  vcsa7@
core@     fd0u3520  nvidia1    sound/   tty29@  tty54@   ttyS21@  ttyS47@  video0@
dmmidi    fd0u3840  nvidiactl  stderr@  tty3@   tty55@   ttyS22@  ttyS5@   vmmon
dsp@      floppy/   port       stdin@   tty30@  tty56@   ttyS23@  ttyS6@   vmnet0
dsp1@     full      ppp        stdout@  tty31@  tty57@   ttyS24@  ttyS7@   vmnet1
dvd@      gpmctl=   psaux@     tts/     tty32@  tty58@   ttyS25@  ttyS8@   vmnet2
fb/       hda       ptmx       tty      tty33@  tty59@   ttyS26@  ttyS9@   vmnet3
fb0@      hda1      pts/       tty0@    tty34@  tty6@    ttyS27@  urandom  vmnet4
fd@       hdb       ram0@      tty1@    tty35@  tty60@   ttyS28@  usb/     vmnet5
fd0@      hdb1      ram1@      tty10@   tty36@  tty61@   ttyS29@  v4l/     vmnet6
fd0d360   hdb2      ram10@     tty11@   tty37@  tty62@   ttyS3@   vbi0@    vmnet7
fd0h1200  hdb5      ram11@     tty12@   tty38@  tty63@   ttyS30@  vc/      vmnet8
fd0h1440  hdc       ram12@     tty13@   tty39@  tty7@    ttyS31@  vcc/     vmnet9
fd0h1476  hdd       ram13@     tty14@   tty4@   tty8@    ttyS32@  vcs@     zero
fd0h1494  initctl|  ram14@     tty15@   tty40@  tty9@    ttyS33@  vcs1@
fd0h1600  input/    ram15@     tty16@   tty41@  ttyS0@   ttyS34@  vcs2@
fd0h360   kmem      ram2@      tty17@   tty42@  ttyS1@   ttyS35@  vcs3@
fd0h720   kmsg      ram3@      tty18@   tty43@  ttyS10@  ttyS36@  vcs4@
fd0h880   log=      ram4@      tty19@   tty44@  ttyS11@  ttyS37@  vcs5@
fd0u1440  loop0     ram5@      tty2@    tty45@  ttyS12@  ttyS38@  vcs6@
fd0u1600  mem       ram6@      tty20@   tty46@  ttyS13@  ttyS39@  vcs7@
fd0u1680  midi      ram7@      tty21@   tty47@  ttyS14@  ttyS4@   vcsa@
root@darkstar:/dev# ismod
-bash: ismod: command not found
root@darkstar:/dev# cd /root/desktop
-bash: cd: /root/desktop: No such file or directory
root@darkstar:/dev# cd /root/Desktop
root@darkstar:~/Desktop# cd drv
root@darkstar:~/Desktop/drv# cd intel-536EP-2.56.76.0/
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# ismod
-bash: ismod: command not found
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# lsmod
Module                  Size  Used by
ppp_deflate             4864  0
zlib_deflate           21912  1 ppp_deflate
zlib_inflate           21248  1 ppp_deflate
bsd_comp                5632  0
ppp_async               9600  1
ppp_generic            23444  7 ppp_deflate,bsd_comp,ppp_async
slhc                    6656  1 ppp_generic
snd_pcm_oss            49704  0
snd_mixer_oss          17408  1 snd_pcm_oss
ipv6                  212064  12
ohci_hcd               18436  0
usblp                  10624  0
via_agp                 6784  1
bt878                   9012  0
tuner                  17036  0
tvaudio                20108  0
bttv                  140236  1 bt878
video_buf              16132  1 bttv
i2c_algo_bit            8840  1 bttv
v4l2_common             5120  1 bttv
btcx_risc               3976  1 bttv
i2c_core               18452  4 tuner,tvaudio,bttv,i2c_algo_bit
videodev                7296  1 bttv
snd_bt87x              12616  0
snd_emu10k1            82184  0
snd_rawmidi            21028  1 snd_emu10k1
snd_pcm                80904  3 snd_pcm_oss,snd_bt87x,snd_emu10k1
snd_timer              21764  1 snd_pcm
snd_seq_device          7304  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         64644  1 snd_emu10k1
snd_page_alloc         10888  3 snd_bt87x,snd_emu10k1,snd_pcm
snd_util_mem            3840  1 snd_emu10k1
snd_hwdep               8196  1 snd_emu10k1
snd                    48484  11  snd_pcm_oss,snd_mixer_oss,snd_bt87x,snd_
 emu10k1,snd_rawmidi,snd_pcm,snd_timer,sn
 d_seq_device,snd_ac97_codec,snd_util_mem
,snd_hwdep
soundcore               6752  2 bttv,snd
emu10k1_gp              2688  0
gameport                3712  1 emu10k1_gp
uhci_hcd               27920  0
ehci_hcd               27012  0
ds                     13572  0
yenta_socket           17536  0
pcmcia_core            52676  2 ds,yenta_socket
nls_utf8                1792  1
ntfs                  113388  1
evdev                   7168  0
agpgart                26920  1 via_agp
psmouse                17544  0
p.s. i see this error when linux loading: " error loading 536epcore "
 
Old 09-05-2004, 06:53 AM   #13
rocco.g
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
see this:
Code:
root@darkstar:~# insmod -f Intel536.o
insmod: can't read 'Intel536.o': No such file or directory
root@darkstar:~# cd Desktop/drv/intel-536EP-2.56.76.0/
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmod -f Intel536
insmod: can't read 'Intel536': No such file or directory
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmod -f Intel536.o
insmod: can't read 'Intel536.o': No such file or directory
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# ls
Intel536.ko     Intel536_inst*  coredrv/      license.txt*  readme.txt*
Intel536_boot*  config_check*   hamregistry*  makefile*
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmod -f Intel536.ko
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# lsmod
Module                  Size  Used by
Intel536             1077764  0
snd_pcm_oss            49704  0
snd_mixer_oss          17408  1 snd_pcm_oss
ipv6                  212064  10
ohci_hcd               18436  0
usblp                  10624  0
via_agp                 6784  1
bt878                   9012  0
tuner                  17036  0
tvaudio                20108  0
bttv                  140236  1 bt878
video_buf              16132  1 bttv
i2c_algo_bit            8840  1 bttv
v4l2_common             5120  1 bttv
btcx_risc               3976  1 bttv
i2c_core               18452  4 tuner,tvaudio,bttv,i2c_algo_bit
videodev                7296  1 bttv
snd_bt87x              12616  0
snd_emu10k1            82184  0
snd_rawmidi            21028  1 snd_emu10k1
snd_pcm                80904  3 snd_pcm_oss,snd_bt87x,snd_emu10k1
snd_timer              21764  1 snd_pcm
snd_seq_device          7304  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         64644  1 snd_emu10k1
snd_page_alloc         10888  3 snd_bt87x,snd_emu10k1,snd_pcm
snd_util_mem            3840  1 snd_emu10k1
snd_hwdep               8196  1 snd_emu10k1
snd                    48484  11  snd_pcm_oss,snd_mixer_oss,snd_bt87x,snd_
 emu10k1,snd_rawmidi,snd_pcm,snd_timer,sn
 d_seq_device,snd_ac97_codec,snd_util_mem
,snd_hwdep
soundcore               6752  2 bttv,snd
emu10k1_gp              2688  0
gameport                3712  1 emu10k1_gp
uhci_hcd               27920  0
ehci_hcd               27012  0
ds                     13572  0
yenta_socket           17536  0
pcmcia_core            52676  2 ds,yenta_socket
nls_utf8                1792  1
ntfs                  113388  1
evdev                   7168  0
agpgart                26920  1 via_agp
psmouse                17544  0
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# insmod -f Intel536.o
insmod: can't read 'Intel536.o': No such file or directory
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# ls
Intel536.ko     Intel536_inst*  coredrv/      license.txt*  readme.txt*
Intel536_boot*  config_check*   hamregistry*  makefile*
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0# cd coredrv/
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0/coredrv# insmod -f Intel536.o
insmod: error inserting 'Intel536.o': -1 Invalid module format
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0/coredrv# insmod -f Intel536.ko
insmod: error inserting 'Intel536.ko': -1 File exists
root@darkstar:~/Desktop/drv/intel-536EP-2.56.76.0/coredrv# hamregistry
no registry file, making default
Code:
If you stick your head in the sand,
one thing is for sure, you're gonna get your rear kicked.

root@darkstar:~# rm /dev/536ep
rm: cannot remove `/dev/536ep': No such file or directory
root@darkstar:~# mknod /dev/536ep
mknod: too few arguments
Try `mknod --help' for more information.
root@darkstar:~# mknod /dev/536ep c 240 1
root@darkstar:~#
i tried to install drivers for kernel 2.6.7 and to run: insmod -f Intel536.ko ...
now the module is in the list...
 
Old 09-05-2004, 09:58 AM   #14
bobwall
Member
 
Registered: Jul 2004
Location: Milpitas, California
Distribution: 1/2 Debian 1/2 my own
Posts: 189

Rep: Reputation: 30
One quick but incomplete test to see if the modem is "cat /dev/modem" (make sure you've made a link to /dev/536ep with "ln -s /dev/536ep /dev/modem" before doing this). If you get a message no such device, then the computer is probably not recognizing the modem. If it doesn't print any error messages, then hit break (ctrl+c) and then start using the modem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to: intel 536EP internal modem Problem anjum SUSE / openSUSE 8 07-29-2005 02:55 PM
problem with 536ep modem soup21 SUSE / openSUSE 7 05-06-2005 07:38 AM
problem with intel(R) 536EP V.92 Modem back-off Linux - Hardware 8 03-08-2005 06:36 PM
Intel 536ep modem installation Nenoslayedme Linux - Hardware 13 08-22-2004 02:05 PM
software modem intel 536ep driver problem jeff1500 Slackware 1 02-27-2004 11:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration