LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-08-2009, 05:03 AM   #1
mahesh_val
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
Unhappy initializations of SDIO card fails - receives same response for all commands -HELP ME


Hi

I have a problem in initialization of sdio card on mips board.The host controller driver at initialization tries to send cmd5 ,cmd3 and cmd7 etc..on to card .. but all the commands sent receive same response value ....I have enabled MMC debug in kernel(using linux 2.6.24) config ..please find the dmesg log below ..

Note: The board works fine for SD card ...

mmc0: clock 400000Hz busmode 1 powermode 2 cs 1 Vdd 21 width 0 timing 0
mmc0: starting CMD0 arg 00000000 flags 000000c0
mmc0: req done (CMD0): 0: 00000000 00000000 00000000 00000000
mmc0: clock 400000Hz busmode 1 powermode 2 cs 0 Vdd 21 width 0 timing 0
mmc0: starting CMD8 arg 000001aa flags 000002f5
mmc0: req done (CMD8): 0: aaaaaaaa 00000000 00000000 00000000
mmc0: starting CMD5 arg 00000000 flags 000002e1
mmc0: req done (CMD5): 0: aaaaaaaa 00000000 00000000 00000000
mmc0: card claims to support voltages below the defined range. These will be ignored.
mmc0: SDIO card claims to support the incompletely defined 'low voltage range'. This will be ignored.
mmc0: clock 400000Hz busmode 1 powermode 2 cs 0 Vdd 21 width 0 timing 0
mmc0: starting CMD5 arg 00200000 flags 000002e1
mmc0: req done (CMD5): 0: aaaaaaaa 00000000 00000000 00000000
mmc0: starting CMD3 arg 00000000 flags 00000075
mmc0: req done (CMD3): 0: aaaaaaaa 00000000 00000000 00000000
mmc0: clock 400000Hz busmode 2 powermode 2 cs 0 Vdd 21 width 0 timing 0
mmc0: starting CMD7 arg aaaa0000 flags 00000015
mmc0: req done (CMD7): 0: aaaaaaaa 00000000 00000000 00000000
mmc0: starting CMD52 arg 00000000 flags 00000195
mmc0: req done (CMD52): 0: aaaaaaaa 00000000 00000000 00000000
mmc0: clock 0Hz busmode 1 powermode 0 cs 0 Vdd 0 width 0 timing 0
mmc0: error -5 whilst initialising SDIO card
mmc0: clock 0Hz busmode 1 powermode 0 cs 0 Vdd 0 width 0 timing 0
 
  


Reply

Tags
driver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless LAN SDIO card - Wrong SDIO driver loaded [i.MX31] Robert_A Programming 2 03-14-2011 11:14 AM
Initialization of sd/sdio card premgda Linux - Embedded & Single-board computer 0 02-21-2008 05:59 AM
No response to many commands roofrack SUSE / openSUSE 5 11-28-2005 11:35 AM
SDIO Wifi card Linux Drivers? mmx87 Linux - Hardware 2 09-06-2004 11:36 AM
Skipping initializations Buttercups Linux - Newbie 1 07-08-2002 03:22 AM


All times are GMT -5. The time now is 04:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration