LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-02-2004, 06:52 PM   #1
FocusedWolf
Member
 
Registered: Feb 2004
Distribution: Fedora Core 3
Posts: 43

Rep: Reputation: 15
imwheel "ldconfig: not found" but its really there... AHHH!


this is very painful sitation

tryint to install imwheel and when i do make install i get errors with this ldconfig command..

i did some googling and found that ldconfig is installed if i type like /sbin/ldconfig...is their a file i have to change in the install or something
***************
Code:
[focusedwolf@localhost imwheel-1.0.0pre6]$ su
Password:
[root@localhost imwheel-1.0.0pre6]# make install
Making install in jax
make[1]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/jax'
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/jax'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/jax'
make[1]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/jax'
Making install in gpm-1.19.3
make[1]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3'
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc'
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/contrib'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/contrib'
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc'
/bin/sh /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/mkinstalldirs \
        /usr/local/man/man1 /usr/local/man/man7 /usr/local/man/man8 /usr/local/info
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc'
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/contrib'
make[2]: Nothing to be done for `installdirs'.
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/contrib'
/bin/sh /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/mkinstalldirs \
/usr/local/lib \
/usr/local/bin \
/usr/local/sbin \
/usr/local/include \
/usr/local/etc
if test "xt-mouse.el t-mouse.elc" != "x" ; then \
        /bin/sh /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/mkinstalldirs /usr/share/emacs/site-lisp ;\
fi
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc'
/bin/sh /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/mkinstalldirs \
        /usr/local/man/man1 /usr/local/man/man7 /usr/local/man/man8 /usr/local/info
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc/mev.1          /usr/local/man/man1
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc/mouse-test.1   /usr/local/man/man1
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc/gpm-root.1     /usr/local/man/man1
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc/gpm-types.7    /usr/local/man/man7
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc/gpm.8          /usr/local/man/man8
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc/gpm.info       /usr/local/info
# Use install-info if available
if /bin/sh -c 'install-info --version' >/dev/null 2>&1; then \
  if [ -f /usr/local/info/dir ] ; then \
        install-info --dir-file=/usr/local/info/dir /usr/local/info/gpm.info; \
  fi; \
fi
#itz Sat Dec 26 23:21:05 PST 1998
#i keep all my infopages compressed and i'm tired to do it by
#hand, so check if there are any compressed pages and do this
#one too
ls /usr/local/info/*[-.]info.gz >/dev/null 2>&1 \
        && gzip -f /usr/local/info/gpm.info
make[2]: [install] Error 1 (ignored)
# Hmm.... shouldn't man pages be compressed too?
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/doc'
make[2]: Entering directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/contrib'
make[2]: Nothing to be done for `install'.
make[2]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/contrib'
/usr/bin/install -c gpm /usr/local/sbin/gpm
/usr/bin/install -c -m 644 libgpm.a /usr/local/lib/libgpm.a
/usr/bin/install -c -m 644 /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3/gpm.h /usr/local/include/gpm.h
for i in mev gpm-root; do \
        /usr/bin/install -c $i /usr/local/bin/$i ;\
done
/usr/bin/install -c -o root -m 755 disable-paste /usr/local/bin/disable-paste
# POSIX requires the range of a for loop be nonempty and Bash
# 2.x goes along; unfortunately that means an additional
# headache in cases like this
if test "xt-mouse.el t-mouse.elc" != "x" ; then \
cd /home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3 && for i in `echo t-mouse.el t-mouse.elc`; do \
        /usr/bin/install -c -m 644 $i /usr/share/emacs/site-lisp/$i ;\
done ; fi
if test "xlibgpm.so.1.18.0" != "x" ; then \
        /usr/bin/install -c -m 644 libgpm.so.1.18.0 /usr/local/lib/libgpm.so.1.18.0 ;\
        cd /usr/local/lib && ln -s -f libgpm.so.1.18.0 libgpm.so ;\
        ldconfig -n -l /usr/local/lib/libgpm.so.1.18.0 ;\
fi
/bin/sh: line 1: ldconfig: command not found
make[1]: *** [install] Error 127
make[1]: Leaving directory `/home/focusedwolf/Desktop/imwheel-1.0.0pre6/gpm-1.19.3'
make: *** [install-recursive] Error 1
[root@localhost imwheel-1.0.0pre6]# ldconfig
bash: ldconfig: command not found
[root@localhost imwheel-1.0.0pre6]#
 
Old 03-02-2004, 07:00 PM   #2
FocusedWolf
Member
 
Registered: Feb 2004
Distribution: Fedora Core 3
Posts: 43

Original Poster
Rep: Reputation: 15
wow i just fixed the problem

if you edit the text file "Makefile" in directory "imwheel-1.0.0pre6/gpm-1.19.3"...where it say ldconfig...change it to /sbin/ldcong

save and rerun make install...seems to installed :P
 
Old 03-02-2004, 07:00 PM   #3
FocusedWolf
Member
 
Registered: Feb 2004
Distribution: Fedora Core 3
Posts: 43

Original Poster
Rep: Reputation: 15
im sure like 100000000 newbies are gonna find this thread now lol
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Successful install" results in "Boot device not found" slackr007 Fedora 2 06-21-2005 05:05 PM
"Successful install" results in "Boot device not found" slackr007 Linux - Newbie 2 05-31-2005 09:02 PM
Couldn't display "SMB:///" , No host "(Null)" could been Found?????? munkey Linux - Newbie 3 05-03-2004 05:30 PM
Couldn't display "SMB:///" , No host "(Null)" could been Found?????? help munkey Fedora 6 04-30-2004 07:04 PM
Anybody having problems with "make" in RedHat 7.3? "cc" not found ? Rampage2884 Linux - General 4 05-14-2002 03:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration