-   Linux - Hardware (
-   -   ieee1394: /dev/raw1394 device node missing (

kevinatkins 01-04-2005 01:42 PM

ieee1394: /dev/raw1394 device node missing

I'm hoping to grab some footage off a DV camcorder. Using Mandrake 10.0, on two machines both fitted with ieee1394 cards, the /dev/raw1394 device node is missing - in spite of the fact that I seem to have the 1394 drivers installed:


[root@study kevin]# lsmod | grep 1394
ohci1394              33956  0
ieee1394              287856  1 ohci1394

So if I try and run Kino, it complains that the 'ieee1394 subsystem is down..'

Am I missing something obvious here? I seem to vaguely remember that 1394 worked just fine when I used SuSE 9...



janic 01-04-2005 10:27 PM

You need to

modprobe raw1394

and the device node _should_ be created. Getting it to work with Kino/dvgrab is another story, see:

for my current situation. It will either "just work" for you, or dvgrab will tell you "no camera exists".

BTW, which DV cam do you have?


kevinatkins 01-05-2005 09:59 AM


thanks for the advice - well, loading the raw1394 module did indeed create the device node, excellent...

unfortunately, still can't get kino to capture - i've checked permissons on the device node and all appears to be in order. strange. i'll keep playing with it while i still have the camera (borrowed from my brother-in-law - it's a Canon, not sure of the exact model, but it's fairly recent)

anyway, thanks for the help - at least i know now why the device node was missing!

if i get any further i'll post back, but i think i'll have to be giving the camera back later today, so i might not get it solved this time around...


J.W. 01-05-2005 03:37 PM

Dunno if this helps but the cover story on the Dec 2004 issue of Linux Journal covered how to set up Kino and make movies. It may be worth a read if you have not already done so. Good luck with it. -- J.W.

link7881 12-16-2008 11:07 AM

Thanks janic for that great link. I checked on it, actually got the same issue with my camcorder. But, I was too late to come across this forum. Had it repaired and checked by a specialist yesterday.

All times are GMT -5. The time now is 07:41 PM.