LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-30-2007, 02:29 AM   #1
Tiger-Striped
LQ Newbie
 
Registered: Aug 2003
Location: Canada..EH!
Distribution: Slackware 12.0
Posts: 20

Rep: Reputation: 0
i855 3d Acceleration on Slackware


Hi everyone,

I've done some research (mind you, I'm still new to linux and I'm starting off with Slackware), and have tried many ways to configure my system to use DRI/XGL for Dropline-Gnome for my Slackware 12 box.

Goal: run display with 3d acceleration at 1400x1050 in 24bit (hopefully 32-bit but 24 is fine)

Graphics card: i855GM with 16MB (reading from the BIOS)
Display: 1400x1050 (max supported)
Processor: Pentium-M 1.4Ghz

This was all done on fresh installs each time just to trace my steps.

Approaches:

1:
I have went through trying 855resolution and 915resolution (using the same methods for both) with the i810 drivers that came with the Slackware 12 DVD. This resulted in no change, so I was still operating at 1024x768.

2:
relating to this site: http://absinthesyringe.blogspot.com/...-120-bugs.html

I went that route and updated the drivers that Patrick V. suggested and then used xorgsetup to run the probe.

Result: KDE loaded first showing the mouse cursor then crashing telling me errors that the font.dir not having permission or not found. So back to square 1, I replaced the back-up xorg.conf and went through the scripts again.

3:
Using methods I have learned from Slackware 11, by adding manually to xorg.conf:

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Options "Composite" "Enable"
EndSection

.... enabling GLX and DRI modules to load as well....

Result: crashing and giving me the message that DRI is built-in and that it was not loaded.

4: After installing both dropline-gnome and compiz-fusion testing with "glxinfo | grep direct" crashes with:Caught signal 11 and a bunch of errors including gobject


Request:

Can someone help me find a solution to this? I'm not quite sure what I'm missing or am doing wrong.

Thanks in advance for the consideration in even reading this.

Cheers,



Tiger-S

Last edited by Tiger-Striped; 10-30-2007 at 02:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Head i855 chipset caps_phisto Fedora 8 01-21-2007 01:34 PM
intel i855 chipset crt flickers when used concurrently with lcd verdeboy2k Linux - Hardware 1 02-26-2006 04:06 AM
ATI 3D Acceleration in Slackware/Debian noxious Slackware 6 01-12-2006 09:27 PM
Acer tm2303wlmi i855.SuSe9.2. 1280x800 doesn't work! k225yt Linux - Laptop and Netbook 3 03-28-2005 06:45 AM
Slackware 10.0 Radeon 8500 no 3d acceleration. wonka_vision Linux - Hardware 0 06-29-2004 03:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration