-   Linux - Hardware (
-   -   I need trackball help! PLEASE! (

Lord Zoltar 07-29-2005 03:45 PM

I need trackball help! PLEASE!
After using a Logitech Trackman Wheel for a couple of weeks, I had to take it back to the store. There were two reasons, its shape was getting uncomfortable, and the tracking in Linux sucked.
I replaced it with a Microsoft TrackBall Explorer. It is more comfortable, and the tracking is better in windows, but the tracking is in some ways worse than the logitech. It shakes and jitters a tiny little bit (a couple pixels) no matter how slow it is moved. The Logitech trackball did this too, but not quite as bad.

Does anyone out there with the TrackBall Explorer (or any other trackball) have advice? I am getting desperate... I can't go back to using a mouse (RIS gets bad everytime I try), and all of these trackballs equally suck in Linux. Anyone?

thanks, in advance.

oneandoneis2 07-29-2005 04:14 PM

I've got a Logitech Trackman Wheel and it works flawlessly. Possibly you got a one-off lousy model, or your own hardware or software has a glitch. . .

Not terribly helpful, I'm afraid, but at least be assured that trackballs *can* work fine in Linux!

Lord Zoltar 07-30-2005 01:15 PM

Even if the Logitech HAD worked flawlessly, it was uncomfortable... too small for my hands. I like the shape and size of the Trackball Explorer better.

Maybe I should have given some more information:


Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
Option "DragLockButtons" "6"
#Option "HWCursor" "true"
#Option "SilkenMouse" "true"
#Option "SWCursor" "false"
#Option "MaxSpeed" "0.001"
#Option "MinSpeed" "0"
Option "Resolution" "2000"

Is what I use for setting up the mouse. The Cursor Settings, the SilkenMouse setting, the DragLock button settings, the Speed settings, and the Resolution setting all seem to have little or no effect. That's why their commented out. Uncommenting doesn't seem to do any harm. My video card is an nVidia GeForce FX 5200 (128 MB Ram), I'm using Kernel (just upgraded yesterday, thought it might help, it didn't. I was using 2.6.10 before). Slackware system (pretty up to date).

I don't know if it's a hardware problem, a problem with my X configuration (maybe in some other file?), a kernel or module problem.... I've SEEN trackballs work under Linux too. I just don't know why I can't get Mine working...

Chromezero 07-30-2005 01:29 PM

Have you tried to run xorgconf? Also, try changing Option "Protocol" "ExplorerPS/2" to Option "Protocol" "IMPS/2". I've always had to change to IMPS/2 to get my mouse working. As far as the resolution goes, setting it to 2000 is too high I think. I could be wrong but I think it should only be around 1600 for that mouse. Just a few things that came to mind right away...

Lord Zoltar 07-30-2005 02:53 PM

The box it came in says it "tracks ball movement 2000 times per second"... but I tried 1600 anyway with IMPS/2 ... no change. :( I'll run xorgconfig when I get home later tonight.

Chromezero 07-31-2005 06:13 AM

I'd go with whatever the manufacturer says on the resolution. Alot of them are set at 1600, in your case I guess it's 2000. I can't really think of any other reasons why it would jitter around, unless it's just something with that mouse in paticular. I'm no guru when it comes to mice, but I'll keep researching. I like a good challenge.

It seems that alot of folks are having that same problem with that mouse, Linux and Windows users alike. One thread I read, although it didn't make much sense, recommended plugging it directly into the the MB instead of through a USB hub. One other thread suggested "breaking it in". They said it was jittery at first but after they had used it a couple days, it smoothed out.

Lord Zoltar 07-31-2005 05:46 PM

I have it plugged into the MB PS/2 port. I've probably seen a lot of the same reviews you've seen (I searched for "Trackball Explorer Review"). a couple people were unhappy, but I think I'd find that with any product review. Since most reviews were quite favourable, I decided to give this trackball a try.

Played around with the settings some more in Windows. I get a very similar jitter problem to what I experience in Linux if I turn the pointer motion speed up very high. So now I think that the only problem is Linux does not have cursor speed adjustment. Yes, I KNOW about `xset m` and it doesn't really help the problem (neither does the KDE mouse control panel).
IS there a way to adjust mouse SPEED (NOT accel or threshold)?
Windows also has another setting called "Enhanced Pointer Precision", which seems to do the opposite of what's it called :confused: can anyone recommend a brand/model of trackball that is known to work very well with Linux (something ergonomic, maybe)? I'm starting to worry this one will never work well... :(

Chromezero 08-04-2005 06:38 AM

I can't recommend any trackballs, since I don't use them. I've tried a few and just never could get comfortable, plus I'm a switch hitter when it comes to using mice. I've run out of ideas with the jitter problem but if I think of something, I'll post back.

DaWallace 08-04-2005 10:29 AM

the track man wheel is a much better product, I ran the trackball explorer into the dust after about 7 months, not only did the ball become extremely stiff due to the scratchy metal pins that hold the ball in, but the ccd broke.

I've had the trackman wheel for about a year and a half, I use it A LOT, the logitech logo on the back has gone from silver to a dull grey, at certain angles you can't even distinguish it from the plastic. and while it has stiffened a bit it works perfectly, I'm definitely going to buy another one of these as soon as I can't take it anymore.

PTrenholme 08-04-2005 10:47 AM

You don't mention the applications you're using with the track ball mouse, nor do you mention if you have the same problem with a "regular" mouse.

If the problem is the same with a "regular" mouse, you've got hardware problems.

If the problem is application specific, it's probably not the hardware.

Although, if you're using Firefox, you might want to try one (or more) of the "smooth wheel" or "smooth scroll" extensions. They curred a lot of jitter on my system.

(By the way, I use a Logitech wireless track ball, and have had problems only in Firefox, which were curred by the above. My system, besides the mouse, is a 3Gh Intel, with 1Gb RAM, nVidia graphics (old MX board))

Hey! I was fooling around, and turned on the "translucency" feature in KDE, and got "jerky" scrolling, bad redraws, etc., etc. ("Translucency" is labeled as an "experimental" option.) Anyhow, all was "smooth" again when I turned it back off.

Lord Zoltar 08-04-2005 10:16 PM

Good question. It is application dependent it would seem. Even before I start a session (when I'm still looking at KDM), the mouse tracks poorly. And the poor tracking is uniform across applications. I don't recall ever seeing motion this bad with my mouse. I may plug it in again later tonight, but I doubt it will bring any revelations. Maybe I'll also try some other sessions (fluxbox, e16...) but I strongly suspect it's a hardware/configuration problem. As I mentioned earlier, when I bootup in Windows, I can get very similar behaviour (jerky, jumpy motion) byt increasing the mouse speed to the maximum that the control panel allows. This option doesn't exist in Linux (only threshold and acceleration, which don't seem to help much), so I think Linux is registering my mouse at maximum speed. So I think Linux can't adjust to the hardware... or something...
I've heard good things about the Kensington Expert Mouse, and I finally found a store near me that sells them. Damn expensive though, but... *sigh*... might just try it anyway.

All times are GMT -5. The time now is 05:59 AM.