LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-29-2008, 10:36 AM   #1
dave45056
LQ Newbie
 
Registered: Aug 2007
Posts: 26

Rep: Reputation: 15
I don't understand how to install a new graphics card in opensuse 10.3


I am running opensuse 10.3 and have a ECS geforce6100sm-m motherboard and an AMD64 Processor.
The MB has onboard video, but its not very good.
So I want to install a new graphics card.
I purchased a geforce7300LE card, but I can't get it to work.
What is the process supposed to be?
Am I supposed to do anything before I install it?
I keep hearing about repositories, but when I boot up with the new card installed I do not get a gui, just text interface.
Can someone help?
Thanks in advance.
 
Old 02-29-2008, 11:14 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,713
Blog Entries: 3

Rep: Reputation: 238Reputation: 238Reputation: 238
you must first make sure your module for that card is installed your distro comes with the generic nvidia card. module it is Located /lib/modules/your modules or in the linux world uname-r/kernel/drivers/video/nvidia. mine is located like yurs here but my name uname-r modules./lib/modules/2.6.23.12/kernel/drivers/video/nvidia . so now you know you have that. shut your computer down install the g-card reboot. and go into bios set up. and enable the agp card or pci card. some bios make you disbale the onboard or let you choose the g-card you want. disable the onboard card and enable the new one. And while you are there set your computer to none os or none plug n play or none windows what ever your bios have. look around you will find it. then save settings, the computer will reboot and you will see your new card and ram. If the screen is blank you did not enable the new card. And then we will have some real problems.
linux will see the new card and load it up. If I was you I would do a yum nvida to make sure you have the newest modules. If this card is new tech. like under a year old you will have to go to nvida where they have a linux section and get it. but I am pretty sure your 10.3 will have it. good luck.
 
Old 02-29-2008, 11:24 AM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,713
Blog Entries: 3

Rep: Reputation: 238Reputation: 238Reputation: 238
login type your user name and password then do a xorgconfig if you have type xorg then push the tab key you will see the commands for xorg if you have xorgsetup use it. if you have xorgcf use that one it will do it all for you then if you cant get the gui to run. then do a xorgconfig
do not forget sudo if your using suse. sudo xorgcfg . if you stiil fail then you need the new moduls at nvidia.a big problem is setting your bios TO none plu n play O/S
 
Old 02-29-2008, 01:14 PM   #4
dave45056
LQ Newbie
 
Registered: Aug 2007
Posts: 26

Original Poster
Rep: Reputation: 15
I Verified the bios is set correctly.
My option is "disable onboard GPU if external GPU is found". That is the only other option besides "enable onboard GPU"
I also made sure that it is set to "non os2"

I also have done the Nvidia 1 click from Opensuse to make sure the repository was up to date.

Then I installed the card. Still I get the text interface. Unfortunately the only option in xorgconfic for nvidia is is the generic one.

Any thoughts on how to proceed?
 
Old 02-29-2008, 01:36 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 732Reputation: 732Reputation: 732Reputation: 732Reputation: 732Reputation: 732Reputation: 732
In xorg.conf, set the video driver to "vesa". This will get you running so you can then run down how to get running with either the "nv" or "nvidia" driver.

Sample from xorg.conf: (non-relevant stuff removed)
Code:
Section "Device"
    Identifier "device1"
    ..
    ..
    Driver "vesa"
    ..
EndSection
 
Old 02-29-2008, 02:33 PM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Try to start up yast2 in text mode goto hardware Graphic card and monitor it should probe you,re card and monitor again
If it the settings are oke save it


Best of luck
 
Old 02-29-2008, 02:47 PM   #7
dave45056
LQ Newbie
 
Registered: Aug 2007
Posts: 26

Original Poster
Rep: Reputation: 15
pixellany,
I tried your suggestion and it still did not boot to a gui.

The "Device" section of my /etc/X11/xorg.conf file looked like this (before change):

BoardName "7300LE"
BusID "0:13:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "nvidia"
EndSection

AFTER the change it looks like this:

BoardName "7300LE"
BusID "0:13:0"
Driver "VESA"
Identifier "Device[0]"
Screen 0
VendorName "nvidia"
EndSection

See anything wrong?
Any more suggestions?
 
Old 02-29-2008, 02:49 PM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 656Reputation: 656Reputation: 656Reputation: 656Reputation: 656Reputation: 656
Does the MB allow you to disable the onboard card in the BIOS settings? SaX seems to work better if there is only one card. If not, look in the xorg.conf manpage. There is an option that you need to explicitly indicate the busID of each card to make sure that the x server doesn't confuse which device section is for which device.

In YaST2 -> Sofware, select "Community Repositories". and add the NVidia repository. That is the easiest way to install the NVidia drivers.
 
Old 02-29-2008, 03:23 PM   #9
dave45056
LQ Newbie
 
Registered: Aug 2007
Posts: 26

Original Poster
Rep: Reputation: 15
Well it seems to be working now.
The suggestion to use yast2 in test mode did the trick.
There was an autodetect that worked well.
Recognized the 7300LE card and monitor.

The only problem now is that the new graphics card appears to be lower resolution than the onboard video... that is: that the desktop icons and text are larger.
The screen resolution is set for 1024x768 and no higher resolutions are offered. The monitor can do 1280x1024, however.

I have not checked the xorg.conf or the repository for nvidia yet, but will later tonight.

One more question... with my OB video I got a spash screen from nvidia during the startup. Now I do not.
does this mean anything?
 
Old 02-29-2008, 03:37 PM   #10
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,216

Rep: Reputation: 294Reputation: 294Reputation: 294
If you are still using vesa driver you won't get a splash - it is the nvidia driver that make the splash unless you turn it off. You need to try to get the nvidia driver working and that way you will probably have better resolution settings.
 
Old 02-29-2008, 11:44 PM   #11
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Go to nvdia site down load the wright driver and install it
If it is installed reboot the system then the driver became activ
To change the resolution start up yast 2 goto graphic card and monitor there you change the resolution and color depth but
you have to be sure to choice the wright settings if the resolution or color depth is wrong the xserver would not start
and then you have to correct via the text mode again


all the best
 
Old 03-01-2008, 07:47 AM   #12
dave45056
LQ Newbie
 
Registered: Aug 2007
Posts: 26

Original Poster
Rep: Reputation: 15
right now the device section in xorg.conf looks like this:

Section "Device"
BoardName "GeForce 7300 LE"
BusID "2:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVIDIA"
EndSection

I still do not get the nvidia splash screen, though.
I'll see what they have on their web site.
Thanks
 
Old 03-01-2008, 08:58 AM   #13
dave45056
LQ Newbie
 
Registered: Aug 2007
Posts: 26

Original Poster
Rep: Reputation: 15
I did check on nvidia's web site.
They recommend to follow the instructions here: http://www.suse.de/~sndirsch/nvidia-...r-HOWTO.html#2

My system is set up exactly like they recommend.
Still no splash screen
Still no 1280 resolution
Still Huge icons on my desktop

Can anyone help?
 
Old 03-01-2008, 10:59 PM   #14
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 656Reputation: 656Reputation: 656Reputation: 656Reputation: 656Reputation: 656
You could select the monitor in Sax2 and add a higher resolution.

Or you could use the "gtf" program to generate your own modeline.
gtf <vertical res> <horizontal res> <refresh rate> -x

Edit out the ".00" in the label after the refresh frequency. Look in the Monitor section corresponding to this monitor. There probably is a: Use "Modes[0]" or Use "Modes[1]" line. If so, then insert your generated Modeline in the corresponding Modes section. In the Screen section for this monitor, add your Modeline label in the Modes line for each resolution.

Code:
Section "Modes"
    Identifier         "Modes[0]"
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "HP"
    ModelName      "ZV5000"
    UseModes       "Modes[0]"
    DisplaySizpe     332    207
    HorizSync       32.0 - 48.0
    VertRefresh     40.0 - 70.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
EndSection
With just one monitor, you may just have "Modes[0]". The UseModes line will tell you which one to use.

Don't simply copy my values in the monitor section. It is for a 1280x800 laptop lcd display. Before SaX2 had an entry for ZV5000, I would have to generate my own modeline with "gtf 1280 800 60 -x".

Here is where you would enter the Modeline labels:
Code:
Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       15
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
EndSection

Section "Extensions"  
    Option         "Composite" "Disable"
EndSection
I don't know if you want 1280x800 or 1280x1024. This example uses "1280x800". Again, don't use a label like "1280x800@60.00". Change it to "1280x800" or "1280x800@60". The latter form may be useful if you generate a Modelines for different refresh rates.

You could simply add "1280x800" (or "1280x1024") to the Modes and see if xorg can perform the modeline calculation automatically when you start up.

Last edited by jschiwal; 03-01-2008 at 11:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSuSE 10.2 can't recognize the onboard intel graphics card ndo SUSE / openSUSE 1 07-19-2007 03:42 AM
Problems with sound and graphics card on opensuse 10.2 on toshiba satellite p100-188 zutty Linux - Laptop and Netbook 4 02-17-2007 09:41 AM
Need graphics card -distros won't install klarsin Linux - Hardware 2 12-08-2006 09:06 PM
openSuse 10.1 ATI 9800 Pro graphics card installed properly? metersmit Linux - Newbie 1 06-05-2006 08:42 PM
I need to install a new graphics card driver matuk_444 Linux - Newbie 11 08-15-2005 02:03 PM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration