LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-28-2005, 04:30 PM   #1
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Rep: Reputation: 15
Question newbie needs help with cd drives


Whenever I try to access my cd drive (or my cd burner) I get the following errors.

Quote:
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
Please check that the disk is entered correctly
and

Quote:
An error occurred while loading devices:/devhdcmntdvd-rom:
Retrieving data from devices is not supported

And when I try to access my burner I get the following (after the drive lights blink for a few seconds.):

Quote:
mount: mount point /mnt/cd-rw is not a directory
Please check that the disk is entered correctly.
And

Quote:
An error occurred while loading devices:/devhddmntcd-rw:
Retrieving data from devices is not supported
Here is my fstab:

Code:
/dev/hda4        swap             swap        defaults         0   0
/dev/hda3        /                ext3        defaults         1   1
/dev/hda2        /ntfs-c          ntfs                         1   0
/dev/hdc         /mnt/dvd-rom     iso9660     noauto,owner,ro  0   0
/dev/hdd         /mnt/cd-rw       iso9660     noauto,owners,ro 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0

Last edited by marco13185; 02-28-2005 at 04:51 PM.
 
Old 02-28-2005, 05:29 PM   #2
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Original Poster
Rep: Reputation: 15
I would imagine that after 16 views someone would have the courtesy to help. The amount of threads that go unanswere here, for such a large community, is amazing. Could someone please help???
 
Old 02-28-2005, 06:48 PM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
To be quite frank with you, I was going to try and give you
some help -- until I noticed your second post. You are selfish,
immature, and in violation of the LQ Rules which you agreed
to abide by when you signed up.

The only advice I have for you is search Google <Linux>, and grow up!
 
Old 02-28-2005, 08:42 PM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Per the LQ Rules, please do not bump your own thread until at least 24 hours have elapsed without a reply. Because the LQ membership is global, people in other time zones may not have seen this post yet, and thus it may take some time before a response is received.

http://www.linuxquestions.org/rules.php

marco13185 - please note that LQ is a 100% volunteer effort, and that all questions should be given at least 24 hours for a response. The LQ membership is spread out across the entire world, and therefore it's possible that someone who can answer your question is in a completely different time zone - what may be early afternoon for you might be the middle of the night for someone else and vice versa.

Similarly, just because a thread may have a number of page views without a response, that scenario does not mean that people are being rude or trying to withhold information from you. Instead, it just means that the people who have seen the thread so far just didn't have any useful advice or suggestions to offer.

I know how frustrating it can be to want to solve a problem but not know how to proceed, but please be patient. If after 24 hours you still have not received a reply, it is OK to bump your own thread, but not before then. Thanks -- J.W.
 
Old 03-01-2005, 07:08 AM   #5
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Original Poster
Rep: Reputation: 15
I apologize for being rude, I was really frustrated as I have had this problem for weeks. Could someone please be kind enough to help me. I never realized that you could not bump your own post until 24 hours later, next time I will read the rules more carefully. But instead of refusing me help could you accept my apology and simply help me.
 
Old 03-01-2005, 07:24 AM   #6
okmyx
Member
 
Registered: May 2004
Location: Cornwall, UK
Distribution: Ubuntu 8.04
Posts: 464

Rep: Reputation: 31
Have the fstab entries been created automatically by your OS or have you entered them manually?

What distro are you using?

Are you trying to mount an audio cd?
 
Old 03-01-2005, 07:47 AM   #7
db391
Member
 
Registered: Jun 2004
Location: Britain
Distribution: Slackware
Posts: 186

Rep: Reputation: 31
Change noauto,owner,ro to noauto,user,ro

You shoudl be able to mount your cds (not audio cds)
 
Old 03-01-2005, 07:48 AM   #8
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Original Poster
Rep: Reputation: 15
No, the original fstab did not work at all, it was missing the RW. I edited it to what it is now. And I use Slackware 10.0. Interesting thing is that on boot the kernel correctly detects the make and model of both drives. After reading a tut online this is my current fstab:

Code:
/dev/hda4        swap             swap        defaults              0   0
/dev/hda3        /                ext3        defaults              1   1
/dev/hda2        /ntfs-c          ntfs        auto                  1   0
/dev/dvd         /mnt/dvd-rom     auto        ro,noauto,user,exec   0   0
/dev/cd-rw       /mnt/cd-rw       auto        noauto,user,ro,exec   0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner          0   0
devpts           /dev/pts         devpts      gid=5,mode=620        0   0
proc             /proc            proc        defaults              0   0
 
Old 03-01-2005, 07:48 AM   #9
db391
Member
 
Registered: Jun 2004
Location: Britain
Distribution: Slackware
Posts: 186

Rep: Reputation: 31
Quote:
Retrieving data from devices is not supported
Recompile your kernel as well.
 
Old 03-01-2005, 07:48 AM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
Try something like this
Code:
/dev/hdc         /mnt/dvd-rom      iso9660     noauto,user,ro   0   0
/dev/hdd         /mnt/cd-rw        iso9660     noauto,user,ro   0   0
And did you create the mount points?
/mnt/dvd-rom
/mnt/cd-rw

How are you mounting? Should be something like
Code:
$ mount /mnt/dvd-rom
$ mount /mnt/cd-rw
This is the error you would get when attempting to mount an audio cd
Code:
mingdao@james:~$ mount /mnt/cdrw 
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       or too many mounted file systems
As okmyx requested, you should state your Linux distribution.
Actually, you should enter it into your LQ UserCP so that question
doesn't have to be answered whenever someone tries to help you.
Different distros do things in different manners. And you should also
post the command or how you tried to mount the device. The more
information you give in your post, and the less someone has to ask
you basic questions, the more replies you'll get...
 
Old 03-01-2005, 07:50 AM   #11
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Original Poster
Rep: Reputation: 15
I have downloaded the 2.6 kernel but it does not extract into a folder as it is supposed to. It extracts into a file that seems to freeze konquerer whenever I move the mouse over it.

I use slack 10.0 (I decided to get into linux the hard way )

How do I create mount points???

Last edited by marco13185; 03-01-2005 at 07:53 AM.
 
Old 03-01-2005, 07:57 AM   #12
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by marco13185
No, the original fstab did not work at all, it was missing the RW. I edited it to what it is now. And I use Slackware 10.0. Interesting thing is that on boot the kernel correctly detects the make and model of both drives. After reading a tut online this is my current fstab:

Code:
/dev/hda4        swap             swap        defaults              0   0
/dev/hda3        /                ext3        defaults              1   1
/dev/hda2        /ntfs-c          ntfs        auto                  1   0
/dev/dvd         /mnt/dvd-rom     auto        ro,noauto,user,exec   0   0
/dev/cd-rw       /mnt/cd-rw       auto        noauto,user,ro,exec   0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner          0   0
devpts           /dev/pts         devpts      gid=5,mode=620        0   0
proc             /proc            proc        defaults              0   0
Three posts at the identical time (9:48 p.m.) -- that has to be some type of record...

One problem is that you have your cd-rw listed as /dev/cd-rw but this is incorrect.
It will be something like /dev/hdx where x is which controller. Do you know where
these devices are located?

/dev/hda = IDE0 master
/dev/hdb = IDE0 slave
/dev/hdc = IDE1 master
/dev/hdd = IDE1 slave

Another problem is the filesystem -- change that auto to iso9660

And use the lines I gave you above for /etc/fstab, changing anything that doesn't
correspond to the drive location on your comp. That comes from a Slack-10.0 box...
 
Old 03-01-2005, 08:00 AM   #13
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Original Poster
Rep: Reputation: 15
I got my dvd-rom to work. I created folders inside mnt called dvd-rom and cd-rw. But for some reason both devices now point to my dvd-rom.
 
Old 03-01-2005, 08:01 AM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by marco13185
I have downloaded the 2.6 kernel but it does not extract into a folder as it is supposed to. It extracts into a file that seems to freeze konquerer whenever I move the mouse over it.

I use slack 10.0 (I decided to get into linux the hard way ;) )

How do I create mount points???
Forget the 2.6.x kernels for now.

Hey -- you didn't get into Linux the hard way, just the best way ;-)

You create mount points like this
Code:
mingdao@james:~$ mkdir /mnt/cd-rw
mkdir: cannot create directory `/mnt/cd-rw': Permission denied
mingdao@james:~$ su -c "mkdir /mnt/cd-rw"
Password: 
mingdao@james:~$ ls -alc /mnt
total 1
drwxr-xr-x  11 root root 264 2005-03-01 21:59 ./
drwxr-xr-x  23 root root 536 2005-03-01 04:13 ../
drwxr-xr-x   2 root root  48 2005-03-01 21:59 cd-rw/
drwxr-xr-x   2 root root  48 2004-09-18 16:10 cdrom/
drwxr-xr-x   2 root root  48 2004-09-25 22:18 cdrw/
drwxr-xr-x   2 root root  48 2004-09-25 22:18 dvd/
drwxr-xr-x   2 root root  48 2004-09-18 16:10 floppy/
drwxr-xr-x   2 root root  48 2004-09-18 16:10 hd/
drwxrwxrwx   2 root root  48 2004-10-15 16:35 sdb1/
drwxrwxrwx   2 root root  48 2004-10-15 16:35 sdc1/
drwxrwxrwx   2 root root  48 2004-10-15 16:36 sdd1/
mingdao@james:~$
You must be root to create a mount point under /mnt but the way I
showed you in this example, you are only root for the duration of that
process, and then it returns you to your regular user account. NEVER
login as root, or run your system as root. Only rookies and stupid guys
do that.

Last edited by Bruce Hill; 03-01-2005 at 08:03 AM.
 
Old 03-01-2005, 08:05 AM   #15
marco13185
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Original Poster
Rep: Reputation: 15
Here is my current fstab:

Code:
/dev/hda4        swap             swap        defaults              0   0
/dev/hda3        /                ext3        defaults              1   1
/dev/hda2        /ntfs-c          ntfs        auto                  1   0
/dev/hdc         /mnt/dvd-rom      iso9660    noauto,user,ro        0   0
/dev/hdd         /mnt/cd-rw        iso9660    noauto,user,ro        0   0
/dev/fd0         /mnt/floppy      auto        noauto,user           0   0
devpts           /dev/pts         devpts      gid=5,mode=620        0   0
proc             /proc            proc        defaults              0   0
Do I have to restart for fstab changes to take effect??

Last edited by marco13185; 03-01-2005 at 08:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
Mount usb drive, umount and mount another drive arubin Linux - Hardware 9 01-17-2007 03:46 AM
USB drive mount double mount issue pazzport Ubuntu 3 10-10-2005 08:28 PM
DVD Drive and CDRW Drive Will not mount on Slackware 10.1 Kernel 2.6.1 necrozen Linux - Hardware 1 09-13-2005 08:21 PM
HELP! Error from mount: drive is write-protected... won't mount writeable. system Linux - General 2 12-27-2001 09:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration