LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-15-2004, 04:05 PM   #1
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
I am unable to get sound


I have a relatively new Slackware 9.1 install wher I cannot get sound working. I have installed the latest version of ALSA and tools. I realize that by default ALSA mutes the volumes but when I changed the levels it still said they were "off" I manuall changed the /etc/asound.state file to get them on (does that sound normal) which I do not recall having to do before. There are some modules being loaded but I do not know if they are correct. It seems strange that lspci would show the modem and sound as so similar. Alsamixer actually says Intel 82801CA Modem, is that normal The second Alsamixer line is as follows:

.
Code:
Cirrus Logic CS4205 rev 3,Silicon Laboratory Si3036/8 rev 1

00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio (rev 02)
Subsystem: Cirrus Logic: Unknown device 5959
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0
Interrupt: pin B routed to IRQ 11
Region 0: I/O ports at d800 [size=256]
Region 1: I/O ports at dc80 [size=64]

00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem (rev 02) (prog-if 00 [Generic])
Subsystem: PCTel Inc Dell Inspiron 2100 internal modem
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0
Interrupt: pin B routed to IRQ 11
Region 0: I/O ports at d400 [size=256]
Region 1: I/O ports at dc00 [size=128]

Lsmod

Module Size Used by Not tainted
parport_pc 14724 1 (autoclean)
lp 6752 0 (autoclean)
parport 23264 1 (autoclean) [parport_pc lp]
uhci 24496 0 (unused)
usbcore 58400 1 [uhci]
snd-intel8x0 18376 0
gameport 1452 0 [snd-intel8x0]
snd-mpu401-uart 3264 0 [snd-intel8x0]
snd-rawmidi 12672 0 [snd-mpu401-uart]
snd-seq-device 3904 0 [snd-rawmidi]
snd-intel8x0m 9740 0
snd-pcm 56416 0 [snd-intel8x0 snd-intel8x0m]
snd-timer 13508 0 [snd-pcm]
snd-page-alloc 6356 0 [snd-intel8x0 snd-intel8x0m snd-pcm]
snd-ac97-codec 43532 0 [snd-intel8x0 snd-intel8x0m]
snd 30148 0 [snd-intel8x0 snd-mpu401-uart snd-rawmidi snd-seq-device snd-intel8x0m snd-pcm snd-timer snd-ac97-codec]
soundcore 3332 0 [snd]
3c59x 26832 0
ohci1394 24200 0 (unused)
ieee1394 42436 0 [ohci1394]
orinoco_cs 4276 1
orinoco 33324 0 [orinoco_cs]
hermes 5732 0 [orinoco_cs orinoco]
ds 6568 3 [orinoco_cs]
yenta_socket 10368 3
pcmcia_core 40032 0 [orinoco_cs ds yenta_socket]
ide-scsi 9424 0
agpgart 39576 0 (unused)

I could sure use some help on this one
 
Old 02-15-2004, 05:39 PM   #2
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Rep: Reputation: 31
To unmute channels, you hit M when you are on a volume channel. I assume editing the text file would have to same effect but you might want to try it in alsamixer first.
 
Old 02-15-2004, 07:46 PM   #3
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Original Poster
Rep: Reputation: 30
I am wondering if ALSA support is compiled. Does anyone know which of the many config options would address this. I looked over my config file and did not see anything that led me to beleive this is a problem on or not. ALSA shipped with the Slack release which leads one to beleive it is supported.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to save sound recording to file jeeva Linux - Software 2 02-01-2005 09:46 AM
Unable to hear sound jeevan Linux - Software 2 10-07-2004 02:56 AM
I am still unable to install my sound driver... SGFHK321 Linux - Newbie 7 07-11-2004 10:41 PM
unable to load alsa sound drivers for als4000 with kernel 2.6.3 qanopus Linux - General 3 03-08-2004 04:03 PM
unable to play more than one sound file at a time. wonka_vision Linux - Hardware 2 06-10-2003 06:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration