LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   I am having an automounting issue with my Optical Drives at boot time (http://www.linuxquestions.org/questions/showthread.php?t=4175442931)

Alpha90 12-25-2012 06:53 PM

I am having an automounting issue with my Optical Drives at boot time
 
When ever my Optical Drive boots with a Read Only CD / DVD in it i get some boot time errors slowing down my boot process. I checked my fstab and both drives have the option noauto but for some reason at boot they mount and the system tries to write to them I believe.

Since my systems fstab file has the option noauto included i performed a test modifying the fstab to remove both optical drives and mount points. But some how that still did not work and they mounted even without a listing in fstab. I am not sure if i am having a caching issue where the system is reading an old fstab or im having some weird mounting issue. Has anyone ever come across something like this? I am running Debian Squeeze with Kernel 3.2.28.

malekmustaq 12-25-2012 09:12 PM

Quote:

But some how that still did not work and they mounted even without a listing in fstab. I am not sure if i am having a caching issue where the system is reading an old fstab or im having some weird mounting issue. Has anyone ever come across something like this?


Everybody running recent linux kernel experience the same. HAL and udev respects the provisions in the /etc/fstab, it is read first and is given priority in the order. If nothing is found there concerning an existing device (say DVD/CD drive) udev creates a /dev/symlink for that automatically; if in case a storage is found therein (a CD or DVD) udev mounts them automatically with the help or (as usual) with the auspices of intrusive mechanisms provided by Kde, Gnome, Xfce or whatever modern DE handles (or grabs) it from the hand of udev --the latter usually sets it to read/write if allowed, if not then an error or informative report is echoed and recorded to the log. To make the media writable the common methods are--

1. Remount it manually with the " -o rw " option;
2. Or automate the process by creating a rule in the /etc/udev/rules.d/70-persistent-blah.
3. Or just nail it at the /etc/fstab for all time.

Hope that helps.

Good luck.


All times are GMT -5. The time now is 09:05 AM.