LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   hwclock did not work! (http://www.linuxquestions.org/questions/showthread.php?t=4175447793)

zh1599512 01-30-2013 12:03 AM

hwclock did not work!
 
Hello All!

When I got a new kernel 2.6.32.60 on a centos x86_64 ,hwclock did not work!

when got the machine start.

it remind that:

hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.

hwclock --debug

hwclock from util-linux-2.13-pre7
hwclock: Open of /dev/rtc failed, errno=19
No usable clock interface found.
Cannot access the Hardware Clock via any known method.

ll /dev/rtc*

crw------- 1 root root 10, 135 01-30 22:46 /dev/rtc
crw------- 1 root root 250, 0 01-30 22:46 /dev/rtc0

but when replaced the hwclock with the system x86's hwclock,it works ,and has no warning message!


is it a bug ?
how to sove it?

linosaurusroot 01-30-2013 04:52 AM

What did the --debug option show you?

zh1599512 01-30-2013 05:31 AM

Quote:

Originally Posted by linosaurusroot (Post 4880563)
What did the --debug option show you?

hwclock --debug

hwclock from util-linux-2.13-pre7
hwclock: Open of /dev/rtc failed, errno=19
No usable clock interface found.
Cannot access the Hardware Clock via any known method.

ll /dev/rtc*

crw------- 1 root root 10, 135 01-30 22:46 /dev/rtc
crw------- 1 root root 250, 0 01-30 22:46 /dev/rtc0

but when replaced the hwclock with the system x86's hwclock,it works ,and has no warning message!


is it a bug ?
how to sove it?


All times are GMT -5. The time now is 01:02 PM.