LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   HVR 1600 Crackling Audio (https://www.linuxquestions.org/questions/linux-hardware-18/hvr-1600-crackling-audio-844472/)

Richard Rahl 11-15-2010 08:47 PM

HVR 1600 Crackling Audio
 
Hello there,

I'm running a Ubuntu 10.04/MythTV Box using a Hauppauge HVR-1600 card.

The card itself seems to work for the most part. I can easily connect my Cable Box via the S-video and Audio-input, and get an audio and video signal by running mplayer /dev/video0 (and MythTV seems to work okay).

Unfortunately, although the audio works, there is a distinctive "crackling" or popping noise in the background. It also causes the audio to get scratchy during Myth recordings. It doesn't seem to be on the line itself, since I still hear it even with the audio cable unplugged. The noise is also clearly recorded into mpg files.

I've been doing some research but can't find any reference to this problem elsewhere with this card, none of the Linux documentation on it even seems to mention it, though I also can't figure out what would be unique about my system. It's just a standard install of 10.04, but with the linux-backports-modules-alsa-lucid-generic installed from when I was trying to get headphone jack sense to work. Otherwise, the audio works fine, there's no popping or crackling in any other applications.

Does anyone have any suggestions on how I might fix the crackling audio? Might it be an issue with the cx18 driver? Thanks for you help.

Kenny_Strawn 11-15-2010 09:28 PM

It could be a problem with your sound card as well -- or maybe with PulseAudio. How is your sound card configured?

Richard Rahl 11-16-2010 06:12 PM

Quote:

Originally Posted by Kenny_Strawn (Post 4160153)
It could be a problem with your sound card as well -- or maybe with PulseAudio. How is your sound card configured?

Thank you very much for your reply. Would you mind elaborating on your question about how it's configured? What information are you looking for specifically?

I can tell you that if I go under Sound Preferences that I have my hardware set to "Internal Audio", 1 Output/1 Input, Analog Stereo Duplex.

Here is the output of cat /proc/asound/cards:

0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xf3ff4000 irq 16

And the output of lspci | grep -i audio

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
02:06.0 Multimedia video controller: Conexant Systems, Inc. CX23418 Single-Chip MPEG-2 Encoder with Integrated Analog Video/Broadcast Audio Decoder

pulseaudio --dump-conf
### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
cpu-limit = no
enable-shm = yes
flat-volumes = no
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-0.9.21/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = speex-float-1
enable-remixing = yes
enable-lfe-remixing = no
default-sample-format = s16le
default-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 8
default-fragment-size-msec = 10
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000

Any additional info that would find helpful, please let me know. Thanks again.

Electro 11-17-2010 08:17 PM

Make sure the Hauppauge HVR-1600 is far way from any heat generating sources. Make sure the cable connection is not touching the case. Also make sure your computer is properly grounded. If it is not properly ground, any problem can come up. You could try in Windows to see if has problems there, but you should find the right firmware if it has no problems in Windows. Though it could be a hardware defect and not software, so you may have to get a replacement.

Another problem could be the on-board sound. The noisy bus could be causing the crackling or other noise. A better sound card like the ASUS Xonar for analog output or use the digital output will not have the problem.

A third problem could be is the volume of your PVR card could be at max, so it is causing distortion which you refer as crackling. Set it around 65% to 70% volume. Setting at 50% if you have a big problem.

Richard Rahl 11-18-2010 10:08 PM

Soundin' Good
 
Quote:

Originally Posted by Electro (Post 4162534)
Make sure the Hauppauge HVR-1600 is far way from any heat generating sources. Make sure the cable connection is not touching the case. Also make sure your computer is properly grounded. If it is not properly ground, any problem can come up. You could try in Windows to see if has problems there, but you should find the right firmware if it has no problems in Windows. Though it could be a hardware defect and not software, so you may have to get a replacement.

Another problem could be the on-board sound. The noisy bus could be causing the crackling or other noise. A better sound card like the ASUS Xonar for analog output or use the digital output will not have the problem.

A third problem could be is the volume of your PVR card could be at max, so it is causing distortion which you refer as crackling. Set it around 65% to 70% volume. Setting at 50% if you have a big problem.

Hey guys, thanks for all your awesome suggestions! I've been out of the Linux community for a long while, but I must say it's nice to be back :)

To answer your question, the card was indeed somewhat close to a heat source, and I've suspected grounding issues since I get some minor interference on my TV and monitor, but I can't help with that, nor can I test on Windows. The volume was already down around 70% from alsamixer.

In the end, loading the kernel module differently seems to have solved the problem.

I was able to rmmod cx18, then load it like so: modprobe cx18 tuner=43 radio=0 (reference: http://ivtvdriver.org/pipermail/ivtv...ay/009392.html)

Testing it in mplayer again, and mythtv, there's no more crackling audio! I still need to test a recording, but I think it'll be okay. In addition, I can now use the analog tuner with ivtv-tune, which I wasn't able to access before with the old (just the s-video). Huzzah :) Thanks again guys.

Electro 11-18-2010 11:14 PM

I did not mean to use alsamixer. I said make sure the PVR cards VOLUME is set at 65% to 70%. This is different than your sound card settings. You will have to use v4l2-ctl to set the volume for the PVR card. The following is what you should use assuming the PVR is /dev/video0 and want to set the volume to about 60%.

v4l2-ctl -d /dev/video0 --set-ctrl volume=60000

Richard Rahl 11-19-2010 05:41 PM

Quote:

Originally Posted by Electro (Post 4163906)
I did not mean to use alsamixer. I said make sure the PVR cards VOLUME is set at 65% to 70%. This is different than your sound card settings. You will have to use v4l2-ctl to set the volume for the PVR card. The following is what you should use assuming the PVR is /dev/video0 and want to set the volume to about 60%.

v4l2-ctl -d /dev/video0 --set-ctrl volume=60000

Oh I see now. I went back and tried that with the audio cracking, but no luck, it didn't seem to help.

For anyone interested, after starting my computer up again this morning the audio crackle was back. The make the driver options persistent across reboots:

1. Create a file in "/etc/modprobe.d" called "cx18.conf" (as root)
2. Add the following line: options cx18 tuner=43 radio=0 (your tuner # may be different)
3. Save the file and restart. The module should now be loaded with the correct options and the cracking should be gone for good.


All times are GMT -5. The time now is 09:27 AM.