-   Linux - Hardware (
-   -   HP PSC 1315 - Printer detected under CUPs but not working (hplip/hpijs driver) (

vharishankar 06-06-2005 09:08 PM

HP PSC 1315 - Printer detected under CUPs but not working (hplip/hpijs driver)
This problem has been solved by me. I have googled around and found that many others have similar problems. Read the problem description below. If you have similar problems printing/scanning with the HP PSC 1310 device (I cannot say whether other HP MFD models will work with this)

The solution has been posted in post #6.


I just installed CUPS and hplip/hpijs for the HP PSC 1315 multifunction printer that I have. The driver recommended was hplip on one website and hpijs on another. So I installed both through synaptic.

CUPs detects the printer as follows:

Printer State: idle, accepting jobs.
Device URI: hp:/usb/psc_1310_series_?serial=MY524CC1F0O2

When I click on print test page in CUPs web-interface or through the HP printer manager (hp-toolbox), I get the following message in jobs


          processing since
Tue Jun 7 07:33:19 2005

But there is no activity in the printer. I am unable to find a solution to this. Is there anything that I have to do or diagnose to find out the solution to this problem?

I can confirm that when the printer is switched off, CUPs identifies this state and gives a message saying that

"open device failed; will retry in 30 seconds..."
Device URI: hp:/usb/psc_1310_series_?serial=MY524CC1F0O2

The printer works fine under Windows. Can anybody help me?


servantofgandalf 06-06-2005 10:36 PM

HP PSC 1315 Printer Issues
I would suggest first uninstalling both drivers, and try the hpijs driver. If that one doesn't work, uninstall it and try the other. The HCL here on claims that the hpijs driver is the one to use with that printer.

I have that printer myself, though I haven't tried to use it with Linux yet... I don't have a working linux machine at this point :cry:

Hope this helps!

vharishankar 06-06-2005 10:44 PM

I'll try with hpijs again, although I'm sure that the hplip driver has superceded both the hpoj and hpijs drivers.

The recommended driver (according to is the hplip driver for this model.

I'll keep everyone up to date on this. I searched google/linux and found a similar thread at but nobody seems to have a solution to this.


vharishankar 06-06-2005 11:42 PM

I keep getting this error when I restart the automatically cancelled jobs:

Just that. How annoying :mad:

vharishankar 06-07-2005 12:33 AM

It works now. I removed the hplip driver and just reconfigured the printer device in CUPs as

Device URI: usb:/dev/usb/lp0
I'm not sure whether changing the URI did it or removing hplip did it. But I'll try both now that I've got it working and see what happens.

Regards. :)

vharishankar 06-07-2005 02:51 AM

Success! Printing and scanning both work with the device HP PSC 1315 Multifunction Printer under Linux. These instructions apply for local USB setup only. Instructions may be different for setting up a remote network printer.

NOTE: If you are a Debian user like me ;), save yourself all the trouble and install CUPS, hpijs, hpoj, sane and other related programs from apt-get or synaptic. All required packages are available from the Debian repositories. :p

<--- BEGIN Debian Related Instructions --->
What (Debian) packages you need (you may not need some of them, but I installed them anyway. Some packages may also be installed as dependencies, but I cannot remember all that so I'm listing them all here ;))
  1. hpijs
  2. hpoj
  3. hpoj-xojpanel
  4. sane
  5. sane-utils
  6. libsane
  7. libsane-extras
  8. Packages related to CUPS
In general, search for all CUPS related packages. If you feel that you may need them, install them. Does no harm at all if you install anything extra. If you don't use Debian, continue below and follow generic installation instructions from the links below.
<--- END Debian Related Instructions --->

Installing CUPS

I assume that you have all installed CUPs. In case you haven't you can find excellent documentation here at:

You can get CUPS here (in case your distro doesn't come with it):

Check out that site. It's great and provides great info on which printers are supported under Linux and which printers are not.

Printing and Scanning Support in HP PSC 1310 series instructions

1. For printing installing the hpijs driver works.
2. For scanning, install the sane utilities and libraries and the hpoj driver.

Detailed instructions for installing these drivers can be found at:

For printing (hpijs installation) check out this page:

For scanning (hpoj installation) check out this thread at

Do NOT install the hplip drivers.

For scanning install the hpoj drivers and then when configuring the device (post-installation), keep the device switched on. This will automatically recognize the device and that's it! All you need to do is to test scan an image using kooka or xsane!

Notes:[list=1][*]You might need to restart the CUPS daemon a few times during the installation process. For this the command is as shown in the next point.[*]Both printing and scanning will work. However, note that sometimes after scanning, printing might not work. The error message might be that the USB port is busy. Try turning off and then turning on the device and if this doesn't work restart the CUPS daemon as root.

/etc/init.d/cupsys restart
(Slackware users might have to type /etc/rc.d/rc.cups restart or a similar command.
  • Keep the device switched off after installing the hpijs driver while adding the printer device using CUPS (Type http://localhost:631 in your browser for CUPS setup). Please select the printer device as (in case you are using a local USB printer) USB Printer #1 in the CUPS printer setup. Make sure that the device URI is usb:/dev/usb/lp0.
  • Keep the device switched on when installing the hpoj drivers. This will automatically detect the device connected to USB port and you need perform no other steps. Just take a sample scan from kooka or xsane to make sure it works.

Best of luck to anybody reading this. If you need any help, please post in this thread :)

Nuselec 06-13-2005 02:34 PM


Thanks for the detail instructions. My printer works, but using CUPS to configure HP PSC 1315/1310 doesn't show up in "Model/Driver for HPPSC1310. Also, the device URI is: ptal:mlc:usb:psc_1310_series_. Mandriva 10.1 is the OS.

What are the commands to print from Firefox and Adobe Reader?



vharishankar 06-14-2005 09:07 PM

Hi, I haven't figured out how to print from Adobe Reader either.

I think that you might have to change the print command in the printing dialog box.

Nuselec 06-14-2005 09:53 PM


Do you know what the command is for Firefox? Also, how many pages per minute do you get?


vharishankar 06-14-2005 10:01 PM


The printing seems to work under Firefox for me. At least the printer seems to respond when I give the print command. I haven't tested with an actual paper yet.

What does the "printer" field say under Firefox?

Also is your printer URI in CUPS?

It should be usb:/dev/usb/lp0 if it is a USB connected printer. This is very important.

Nuselec 06-15-2005 03:40 PM



What does the "printer" field say under Firefox?
lpr -P HPPSC1310


Also is your printer URI in CUPS?

It should be usb:/dev/usb/lp0 if it is a USB connected printer. This is very important.
Look at my first post. Using CUPS, the driver for HP PSC 1310 is NOT listed. Days ago, when I tried what you suggested, the printer didn't work.

Thanks for you reply.

vharishankar 06-15-2005 09:16 PM

I don't get it. When the device list appears, you should choose

USB Printer #1 (for USB connected printer)

The driver *will* be listed for HP PSC 1310 series in the next screens.

In the Make screen, choose HP and in the next one, choose HP PSC 1310 Foomatic/hpijs (recommended).

Do not choose the device URI as hp:/usb/psc_1310_series_?serial=MY524CC1F0O2.

Three suggestions:

1) There is no reason why it should not work if you've installed the hpijs driver.

2) Make sure also that you have the latest version of CUPS.

3) Can you post screenshots of your CUPS configuration page so that I can check if there's anything you've missed?

Nuselec 06-17-2005 06:41 PM


One thing I didn't mention, there's another printer listed (right now it's not hooked up to the computer)

Once USB Printer #2 was selected, the rest was as you said.

CUPS-1.1.21-0.rc.1.7.4 is the version installed. (It's not the lastest, but this should still work, shouln't it?)

With the configuration as it is now, I can't print.

Under "Forum Rules" it says "You may not post attachements." So I can't post the screenshoot, but basically what it shows is listed below.

Default Destination: HPPSC1310

EPSONStylusC82 Epson Stylus C82 Foomatic/gimp-print-ijs (recommended)
Description: EPSON Stylus C82
Printer State: idle, accepting jobs.
Device URI: usb://EPSON/Stylus%20C82

HPPSC1310 HP PSC 1310 Foomatic/hpijs (recommended)
Description: HP PSC 1310
Printer State: processing, accepting jobs.
"Printer not connected; will retry in 30 seconds..."
Device URI: usb:/dev/usb/lp1

Mandriva 10.1 is the OS.



vharishankar 06-17-2005 09:52 PM

Did you try removing the other printer's configuration?

Also I had this problem

Printer State: processing, accepting jobs.
"Printer not connected; will retry in 30 seconds..."

But it usually works after I restart CUPS. Also did you activate the printer using the CUPS configuration "Start Printer" button?

Sorry I cannot think of anything else that might be a problem there!


Nuselec 06-18-2005 09:38 AM


Did you try removing the other printer's configuration?
No, but it shouldn't make a difference.


Also did you activate the printer using the CUPS configuration "Start Printer" button?


Sorry I cannot think of anything else that might be a problem there!
Harishankar, thank you for your patience and continual assistance. :D

Maybe in the near feature, printing in Linux will be straightforward . It will be simple to print from Web browsers, Adobe Reader etc...


All times are GMT -5. The time now is 07:18 AM.