-   Linux - Hardware (
-   -   HP printer stopped working (

sharky 03-31-2012 09:13 AM

HP printer stopped working
Printer is HP Officejet 4500 Wireless

OS is Mint Linux 10

When I first bought the printer I was able to set it up through the Mint Linux "Printing" utility in the Mint Linux Control Center. It worked fine for several weeks. Then my router died so I replaced it. Since then I haven't been able to scan or print. Prints just hang in the queue and not scanner is detected.

I have deleted the printer from the queue and reconnected through the printer utility. It is still found and setup just like I did when I first bought it but nothing actually works.

I can print a test page directly from the printer but nothing works through the wireless network.

With the new router I setup my network with the same name and pass phrase and at the printer is says it is successfully connected. The router also shows the MAC id of the printer as a connected device.

So the system and printer indicate that it is connected but when I actually try to use the printer is acts like it is not connected.

Any advice or suggestions are welcome.

frankbell 03-31-2012 09:01 PM

For testing purpose, I would install HPLIP and see whether I can install the printer with it. It should be in the repos.

sharky 04-02-2012 05:13 PM

Tried to install hplip and system indicated that it was already installed.

Tried to invoke 'hplip' and got "command not found" returned. How do I use HPLIP?


Originally Posted by frankbell (Post 4641731)
For testing purpose, I would install HPLIP and see whether I can install the printer with it. It should be in the repos.

michaelk 04-02-2012 05:36 PM

You should have these utilities installed on your system:

You can use hp-probe to search for your printer. Via CUPS make sure that the printer spooler is not paused and that you do not have any pending jobs that have not printed yet.

sharky 04-04-2012 10:13 AM

Used CUPS. Cups was able to find and correctly identify the printer. I then selected the driver for my printer which was listed. However, nothing prints. Print jobs sent to the printer just hang.

This is really confusing. When I bought the printer it worked right away and since replacing the router it refuses to work. I'm sure it properly connected. It shows on the printer that it is connected to my wireless network and the CUPS utility finds the printer. Everything "looks" OK. It just doesn't respond to print jobs.

hp-info and hp-probe returns "No devices found".

michaelk 04-04-2012 02:02 PM

May need to specify what to search for:
hp-probe -bnet

sharky 04-05-2012 09:33 AM


Originally Posted by michaelk (Post 4644774)
May need to specify what to search for:
hp-probe -bnet

Used hp-setup. It could not detect the printer. Used USB option where it sets it up via a USB cable. Setup continually failed to work despite printer being detected.

I checked my router and noticed that it did not assign an IP to my printer. The router is netgear. Any ideas why it will not assign an IP?

sharky 04-05-2012 10:58 AM

Disconnected the printer at the printer. Also switched from "automatic" to "manual" and back to automatic.

Then unplugged the router and plugged it back in.

Then setup wireless and the printer again. This time the router assigned an IP.

With the IP I was able to setup the printer and now it works.

All times are GMT -5. The time now is 02:01 AM.