LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   HP Officejet 6300 USB printer spools but does not print (https://www.linuxquestions.org/questions/linux-hardware-18/hp-officejet-6300-usb-printer-spools-but-does-not-print-515761/)

ytrottier 01-02-2007 10:31 PM

HP Officejet 6300 USB printer spools but does not print
 
I just installed an HP USB printer, but the test page does not print. I would appreciate any suggestions for diagnosis procedures.

Printer: HP Officejet 6310, connected locally by USB
Kernel: 2.6.12-12mdk
Distro: Mandriva 2006
Uninstalled kdelibc1 in order to install conflicting PyQt-3.14.1-1
Installed hplip-1.6.12 (which required the PyQt 3.14)
hp-setup correctly detected an HP Officejet 6300 series printer.
KDEprint shows jobs are queued and processing, but nothing happens.
Rebooting computer or restarting CUPS has no effect.

dmesg excerpts:
Code:

usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
PCI: Setting latency timer of device 0000:00:1f.4 to 64
uhci_hcd 0000:00:1f.4: UHCI Host Controller
uhci_hcd 0000:00:1f.4: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:1f.4: irq 23, io base 0x00002440
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ts: Compaq touchscreen protocol output
usb 1-1: new full speed USB device using uhci_hcd and address 2
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x03F0 pid 0x5311
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb-storage: device scan complete
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport0: irq 7 detected
lp0: using parport0 (polling).
lp0: console ready
drivers/usb/class/usblp.c: usblp0: removed

Code:

# lsusb
Bus 001 Device 002: ID 03f0:5311 Hewlett-Packard
Bus 001 Device 001: ID 0000:0000

/etc/cups/cupsd.conf excerpts:
Code:

LogLevel info
TempDir /var/spool/cups/tmp
Port 631
BrowseAddress @LOCAL
BrowseDeny All
BrowseAllow 127.0.0.1
BrowseAllow @LOCAL
BrowseOrder deny,allow
<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
Allow From @LOCAL
</Location>
<Location /admin>
AuthType Basic
AuthClass System
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>

The rest of cupsd.conf appears to be commented out. I just changed LogLevel to debug, and will test tomorrow. In the meantime, please suggest what else I should check.

ytrottier 01-03-2007 01:58 PM

usblp0 removed
 
I think I´ve narrowed down the problem:
Code:

# cat /proc/bus/usb/devices | grep Driver
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=cc Prot=00 Driver=(none)
I:  If#= 1 Alt= 0 #EPs= 3 Cls=07(print) Sub=01 Prot=02 Driver=usbfs
I:  If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I:  If#= 2 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=d4 Prot=00 Driver=(none)
I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

The absence of usblp0 is bad according to O´Reilly, but no solution is offered. dmesg up above does note the removal of usbpl0 following (parallel port polling?), but does not say why. How do I get my usblp0 back?

ytrottier 01-03-2007 05:24 PM

RESOLVED
by urpmi libnet-snmp5-devel-5.2.1.2-4mdk
and fully uninstalling and reinstalling HPLIP.

I don´t know why this worked. I did it because HPLIP said libnetsnmp-devel was an optional dependancy, required for connecting by ethernet as opposed to USB. I was going to try ethernet next, but couldn´t for lack of an available hub port. And then the USB connection worked.

cat /proc/bus/usb/devices | grep Driver
still does not return usblp0.
usblp0 is still removed in dmesg.

I guess libnetsnmp-devel is not so optional, whereas usblp0 is. You know, it´s the first time I´ve found a mistake in an O´Reilly book.


All times are GMT -5. The time now is 06:35 PM.