-   Linux - Hardware (
-   -   HP LaserJet Professional M1217nfw MFP hplip hp-setup binary plugin won't download (

scheidel21 05-10-2012 08:56 PM

HP LaserJet Professional M1217nfw MFP hplip hp-setup binary plugin won't download
I have an HP LaserJet Professional M1217nfw MFP printer networked via WiFi. I also have a RedHat Enterprise Linux 5 box that I need to add this printer to. I have the hplip package downloaded and installed, and according to the documentation this printer is supported, albeit a proprietary binary plugin needs to be downloaded and installed using the hp-setup program or hp-plugin program. When I run the hp-setup utility and pass the IP address to it it finds the printer a starts the motions to install the printer, but then fails claiming it is an unsupported printer model. If I run the hp-plugin utility to just download the binary plugin and install the printer manually in CUPS, the utility encounters some sort of python error. I have checked the models.dat file which lists the hp-setup supported models and the configuration settings to install the printers. The M1217nfw is clearly listed in the file. I cannot seem to find the download location for this binary plugin to manually download it either.

So after this long intro my question is: Does anyone have any ideas on how I can get this printer installed?

tronayne 05-12-2012 09:07 AM

Do you have the current HPLIP? That's 3.12.4. You can download the tarball for it at or start at for a specific distribution download.

Have you looked at the HPLIP Binary Plugin article? See, may be some help there (check the links in the page). Too, installing logged in as root (or su - or perhaps sudo) generally works.

Hope this helps some.

scheidel21 05-13-2012 08:21 PM

Thanks for responding, I suppose updating to the latest HPLIP is an option thought the repository version is 3.10.2 which is, according to the documentation able to support this printer, but short of plugging it into an Ethernet port instead of connecting wirelessly I am getting to a running out of ideas stage.

tronayne 05-14-2012 07:40 AM

I seem to remember that there were some problems with 3.10.x (and with Ghostscript, which ought to be at 9.02 or higher although that's got nothing to do with your problem but you might want to get that while you're at it). Probably be a good idea to upgrade (can't hurt, might help, eh?). H-P does a pretty good job of keeping HPLIP upgraded; when they find out there's a problem they fix it (quick) and it never hurts to take advantage of that.

scheidel21 05-17-2012 08:01 PM

Installed the latest hplip and I have the same issue :-(

scheidel21 05-17-2012 09:47 PM

Got it, I think, I have to confirm that the test page came out, but I ended up having to remove the installed package and then performing the manual install instructions for hplip.

All times are GMT -5. The time now is 01:47 PM.