-   Linux - Hardware (
-   -   HP F4480 all-in-one doesn't scan but prints (copies) (

JBComputers 05-08-2010 11:55 AM

HP F4480 all-in-one doesn't scan but prints (copies)
Hello there. I have recently purchased an HP F4480 all-in-one printer.

The printer part works, and so does copies (I think all copiers work without needed to be plugged into the PC).
It however won't scan. I'm assuming I am missing some driver for it, but I can't seem to find it. I have even tried contacting HP support but no luck.
I'm a tad surprised, I heard HP was great with Linux.

Anyway, I tried to find the scanner manually, in the Control Center, tried sane, xsane, kooka. Nothing is detecting this printer.

If it matters, I am using Mandriva 2009.1 Powerpack edition.

Any help would be greatly appreciated. Thank you.

thorkelljarl 05-09-2010 11:29 AM

Are you using...

There is a HPLIP driver for this all-in-one. The HPLIP drivers include support for scanner function. If you are using the driver without achieving success with the scanning function, post back.

JBComputers 05-09-2010 12:49 PM

I'm getting this problem:

[root@localhost jeremy]# su - -c "urpmi --allow-force --force --auto cups cupsddk cupsddk-drivers cups-devel libdbus-1-devel gcc-c++ ghostscript libcryptopp5 libcryptopp5-devel libjpeg62-dev libsnmp0-devel glibc-i18ndata glibc_lsb libtool libusb0.1_4-devel make python-imaging python-qt4 dbus-python python-dbus python-gobject python-devel python python-reportlab sane libsane1-devel sane-frontends sane-backends xsane"
No package named libcryptopp5
No package named libcryptopp5-devel
No package named libjpeg62-dev
The following packages contain libjpeg62-dev: libjpeg62-devel
You should use "-a" to use all of them
Packages xsane-0.996-1mdv2009.1.i586, python-qt4-4.5.2-0.3mdv2009.1.i586, python-imaging-1.1.6-6mdv2009.1.i586, python-gobject-2.16.1-3.1mdv2009.1.i586, sane-backends-1.0.19-7.1mdv2009.1.i586, python-dbus-0.83.0-4mdv2009.1.i586, cupsddk-drivers-1.2.3-3mdv2009.1.i586, python-reportlab-2.2-2mdv2009.1.i586, cups-1.3.10-2.1mdv2009.1.i586, python-2.6.1-6.3mdv2009.1.i586, ghostscript-8.64-65.1mdv2009.1.i586 are already installed
medium ""Mandriva Linux - 2009 Spring (Powerpack) - restricted"" is not available
[root@localhost jeremy]#

LinuxAisle 05-09-2010 02:56 PM


Do you know anything about getting the scan button to work? It's not recognized as a key-press in xev, I'm just wondering if there's some driver I can install to get it working. I do have HPLIP & CUPS installed as well. I have a Deskjet F4280 that prints perfectly from Linux.


All times are GMT -5. The time now is 05:42 AM.