-   Linux - Hardware (
-   -   HP Deskjet 5550 (usb) - HPLIP can't run in Debian sarge (

ch_music 02-03-2005 08:10 PM

HP Deskjet 5550 (usb) - HPLIP can't run in Debian sarge
Dear all,

I have a Deskjet 5550 printer connected to my linux box with usb. Currently, I have difficulties in installing the HPLIP 0.8.7 driver ( The last step of the installation:

# /etc/init.d/hplip restart

Stopping hpiod [OK]
Stopping hpssd [OK]
Starting hpiod [OK]
Starting hpssd [FAILED]

I am using Debian sarge with kernel 2.6.8 for k7. I tried both compiling from source code (with dpkg and manual) and apt-get install package from Debian Unstable (no dependencies error is reported with apt-get). Both return the same error.

cupsd is running but I cannot access http://localhost:631/ (to install the printer according to HP instruction). I don't know whether this is because my hpssd failed to load or because of cupsd problem.

Thus, currently I can't print anything. This is the first time I'm installing a printer in my system, so any help will be greatly appreciated!! Thanks... :D


jarobman 02-11-2005 04:15 AM

I'm having the same problem with my hp 3650. Hopefully, someone will give us a solution...

AnderWinkler 02-12-2005 02:00 PM

Regarding the hpssd, I have the same problem and I'm trying to solve it.

About the localhost:631, try to activate the loopback before:

ifconfig lo up

it worked for me.

ch_music 02-12-2005 06:34 PM

Hey, I just reinstalled Debian on my new harddrive. I just finished the installation yesterday morning. So far everything works fine, including hpssd. I think it might be some dependency problems or errors. I installed everything from scratch (net-install).

jarobman 02-12-2005 09:57 PM

I solved the problem. It seems that I was having some dependency issues. I was missing some python related packages and some others as well. All I did was go into YAST (I guess its obvious now that I use SUSE) and install the packages that I was missing. I ran /etc/init.d/hplip restart and hpssd was able to be restarted successfully.

Here is a helpful link for any one viewing this thread:

All times are GMT -5. The time now is 01:21 AM.